Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/smclient/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-08-31 15:20:43 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-08-31 15:20:43 (GMT)
commit83a7a11ba109b8aee5cdc047dec8b93967ccfc0e (patch)
treeadc1a8b56abf1f8bffc85a8faeb4e90e4ac2c71a /cut-n-paste/smclient/Makefile.am
parent216f093dc323646d127a4b66af1179e6c1011f47 (diff)
EggSMClient copied from libegg
2008-08-31 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/Makefile.am: * cut-n-paste/smclient/Makefile.am: * cut-n-paste/smclient/eggdesktopfile.[ch]: * cut-n-paste/smclient/eggsmclient-private.h: * cut-n-paste/smclient/eggsmclient-xsmp.c: * cut-n-paste/smclient/eggsmclient.[ch]: EggSMClient copied from libegg * libdocument/ev-file-helpers.c: (ev_dot_dir): * shell/Makefile.am: * shell/ev-application.[ch]: (ev_application_load_session), (smclient_save_state_cb), (smclient_quit_cb), (ev_application_init_session), (ev_application_shutdown), (ev_application_init): * shell/main.c: (main): Use EggSMClient instead of gnome-client and remove libgnome and libgnomeui dependencies. svn path=/trunk/; revision=3130
Diffstat (limited to 'cut-n-paste/smclient/Makefile.am')
-rw-r--r--cut-n-paste/smclient/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/cut-n-paste/smclient/Makefile.am b/cut-n-paste/smclient/Makefile.am
new file mode 100644
index 0000000..3cb7725
--- /dev/null
+++ b/cut-n-paste/smclient/Makefile.am
@@ -0,0 +1,21 @@
+noinst_LTLIBRARIES = libsmclient.la
+
+libsmclient_la_SOURCES = \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
+ eggsmclient.c \
+ eggsmclient.h \
+ eggsmclient-private.h \
+ eggsmclient-xsmp.c
+
+libsmclient_la_CFLAGS = \
+ -I$(top_srcdir)/lib \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ -DEGG_SM_CLIENT_BACKEND_XSMP \
+ $(SMCLIENT_CFLAGS) \
+ $(WARNING_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+libsmclient_la_LIBADD = \
+ $(SMCLIENT_LIBS) \
+ -lSM -lICE