Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2005-03-01 22:24:10 (GMT)
committer Kristian Høgsberg <krh@src.gnome.org>2005-03-01 22:24:10 (GMT)
commit02eb16fef45712a91e24f6471b9e2f31249c888e (patch)
treed5579258f1d7fbd5a280fb2f1b97b74004b1dea9 /pdf/Makefile.am
parent332afee84ff4eb7df326d96f07efd6f82a87c0a2 (diff)
Use poppler instead of including xpdf source code. Poppler is a fork of
2005-03-01 Kristian Høgsberg <krh@redhat.com> Use poppler instead of including xpdf source code. Poppler is a fork of xpdf to build it as a shared library. See http://freedesktop.org/wiki/Software/poppler. * pdf/xpdf/*, pdf/goo/*, pdf/splash/*, pdf/fofi/*: Remove included xpdf fork. * pdf/Makefile.am: Build libpdfdocument.a here. * pdf/GDKSplashOutputDev.cc: * pdf/GDKSplashOutputDev.h: * pdf/GnomeVFSStream.cc: * pdf/GnomeVFSStream.h: * pdf-document.cc: * pdf-document.h: * test-gdk-output-dev.cc * Thumb.cc: * Thumb.h: Pull these files out of pdf/xpdf and adjust to compile against poppler.
Diffstat (limited to 'pdf/Makefile.am')
-rw-r--r--pdf/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/pdf/Makefile.am b/pdf/Makefile.am
index b8fe1da..4604706 100644
--- a/pdf/Makefile.am
+++ b/pdf/Makefile.am
@@ -1,3 +1,27 @@
-SUBDIRS = goo fofi splash xpdf
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/backend \
+ $(POPPLER_CFLAGS) \
+ $(GTK_CFLAGS) \
+ -DDATADIR=\""$(datadir)"\"
-EXTRA_DIST = aconf.h aconf2.h
+noinst_PROGRAMS = test-gdk-output-dev
+
+noinst_LTLIBRARIES = libpdfdocument.la
+
+libpdfdocument_la_SOURCES = \
+ GDKSplashOutputDev.cc \
+ GDKSplashOutputDev.h \
+ Thumb.cc \
+ Thumb.h \
+ pdf-document.cc \
+ pdf-document.h
+
+test_gdk_output_dev_SOURCES = \
+ test-gdk-output-dev.cc
+
+test_gdk_output_dev_LDADD = \
+ libpdfdocument.la \
+ $(top_builddir)/backend/libevbackend.la \
+ $(POPPLER_LIBS) \
+ $(GTK_LIBS)