Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <mmeeks@src.gnome.org>1999-08-18 18:11:18 (GMT)
committer Michael Meeks <mmeeks@src.gnome.org>1999-08-18 18:11:18 (GMT)
commit1a49446c08faaab930d3a36bc002b566eadb1ebc (patch)
treee94976cc44a9f50cd5df1a43ac49ba1452ab145b /pdf/xpdf/Makefile.am
parent378a46975316cb7addf8ea8cd0b74c7144588357 (diff)
embryonic PDF viewer as a Bonobo container...
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index 7748064..606479c 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -12,7 +12,7 @@ gui = xpdf
endif
#bin_PROGRAMS = pdftops pdftotext pdfinfo pdftopbm pdfimages $(gui) bonobo-image-x-pdf
-bin_PROGRAMS = bonobo-image-x-pdf
+bin_PROGRAMS = bonobo-image-x-pdf gpdf
common_sources = \
Array.cc \
@@ -40,16 +40,20 @@ common_sources = \
TextOutputDev.cc \
XRef.cc
-gpdf_CFLAGS =
+gpdf_CFLAGS = \
+ -DBONOBO_IO
gpdf_SOURCES = \
- $(common_sources) \
- GOutputDev.cc \
gpdf.cc
gpdf_LDADD = \
+ $(GTK_LIBS) \
+ $(GNOME_LIBDIR) \
+ -lbonobo \
+ $(GNOMEGNORBA_LIBS) \
$(EXTRA_GNOME_LIBS) \
- ../goo/libgoo.a
+ $(INTLLIBS)
+
bonobo_image_x_pdf_SOURCES = \
$(common_sources) \