Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <mmeeks@src.gnome.org>1999-08-15 21:06:36 (GMT)
committer Michael Meeks <mmeeks@src.gnome.org>1999-08-15 21:06:36 (GMT)
commit2610a3462d1ac3f20cba8f16dd07cba8a8c2fbef (patch)
tree525fe32ba24e40e515aba0e4f7fb66b38941853d /pdf/xpdf/Makefile.am
parentc43ab012d25e32fe019d4654e1994ad3edd618dd (diff)
Break everything except bonobo-image-x-pdf :-)
New cleaner xpdf IO code. use make bonobo-image-x-pdf in xpdf to compile.
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index 6c6ceb0..7d2be72 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -13,8 +13,9 @@ endif
bin_PROGRAMS = pdftops pdftotext pdfinfo pdftopbm pdfimages $(gui) bonobo-image-x-pdf
-common_sources = \
+common_sources = \
Array.cc \
+ BaseFile.h \
Catalog.cc \
Dict.cc \
Error.cc \
@@ -51,9 +52,14 @@ gpdf_LDADD = \
bonobo_image_x_pdf_SOURCES = \
$(common_sources) \
+ BonoboFile.h \
+ BonoboFile.cc \
GOutputDev.cc \
bonobo-image-x-pdf.cc
+bonobo_image_x_pdf_CFLAGS = \
+ -DBONOBO_IO
+
bonobo_image_x_pdf_LDADD = \
../goo/libgoo.a \
$(GTK_LIBS) \