Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael@helixcode.com>2000-10-17 20:30:53 (GMT)
committer Michael Meeks <mmeeks@src.gnome.org>2000-10-17 20:30:53 (GMT)
commit6d6a1a5cf8d99a12293b0f31669e8b017c3f73c9 (patch)
tree61ef93ae9e9f38ac7539619590cdaef7c38b3611 /pdf/xpdf/Makefile.am
parent20a313181309084425a75c001145ea43c14d014a (diff)
add.
2000-10-17 Michael Meeks <michael@helixcode.com> * gpdf.xml: add. * Makefile.am: sort out xml files. * gpdf.cc: Re-engineer to the new UI handler. * bonobo-application-x-pdf.cc: update to new UI handler * bonobo-appliation-x-pdf-ui.xml: create. * gpdf-ui.xml: create. 2000-10-17 Michael Meeks <michael@helixcode.com> * Makefile.am (WIN32_EXTRA): remove cruft so we distcheck. 2000-10-17 Michael Meeks <michael@helixcode.com> * POTFILES.in: add generated files.
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index 3d42d01..01bf1f7 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -8,6 +8,7 @@ endif
INCLUDES = \
-I$(top_srcdir)/goo \
-I$(top_srcdir)/ltk \
+ -DDATADIR=\""$(datadir)"\" \
$(EXTRA_GLIB_CFLAGS) \
$(EXTRA_GNOME_CFLAGS)
@@ -180,4 +181,19 @@ endif
GOAD_FILES = application-x-pdf.gnorba
OAF_FILES = application-x-pdf.oafinfo
-EXTRA_DIST = $(bitmaps) ChangeLog $(ltk) $(GOAD_FILES) $(OAF_FILES) config.h
+XML_FILES = \
+ gpdf-ui.xml \
+ bonobo-application-x-pdf-ui.xml
+
+uidir = $(datadir)/gnome/ui
+ui_DATA = $(XML_FILES)
+
+BUILT_SOURCES=$(XML_FILES:.xml=.h)
+
+%.h : %.xml
+ bonobo-ui-extract $^ > $@
+
+EXTRA_DIST = $(bitmaps) ChangeLog $(ltk) $(GOAD_FILES) \
+ $(OAF_FILES) config.h $(XML_FILES)
+
+