Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMartin Kretzschmar <mkretzschmar@src.gnome.org>2003-02-23 13:35:35 (GMT)
committer Martin Kretzschmar <mkretzschmar@src.gnome.org>2003-02-23 13:35:35 (GMT)
commit939b9d12f2919ceea85575e6b7e1d67874da91a8 (patch)
tree5883ee7aecd09f877509316678ae5bc164dbd0b4 /pdf/xpdf/Makefile.am
parent12bafbb7ffef77d5b5b948bbe8c49fe9497d9d9d (diff)
new widget: table with labels displaying properties of PDFs
* xpdf/pdf-properties-display.c, xpdf/pdf-properties-display.h, xpdf/gpdf-properties-dialog.glade: new widget: table with labels displaying properties of PDFs * xpdf/gpdf-control.cc (has_unicode_marker) (utf16_big_endian_to_utf8, info_dict_get_string) (info_dict_get_date, gpdf_control_process_string_property) (gpdf_control_process_date_property) (gpdf_control_process_properties) (gpdf_control_properties_dialog_response_cb) (verb_FileProperties_cb): new: a PDF properties command * xpdf/Makefile.am: build pdf-properties-display.[ch], install glade file * xpdf/.cvsignore: ignore gpdf-properties-dialog.gladep * xpdf/gpdf-persist-stream.h, xpdf/gpdf-persist-stream.cc (gpdf_persist_stream_get_length): new function * xpdf/gpdf-control-ui.xml: add FileProperties command and menu item inside a "File Items Placeholder" * shell/gpdf-window-ui.xml: add "File Items Placeholder" * configure.in: check for libglade-2.0 * Makefile.am (EXTRA_DIST): don't dist gpdf.mime * xpdf/PDFDoc.cc, xpdf/Function.cc, xpdf/FontFile.cc, goo/parseargs.c: call atof only in the "C" locale
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index dbaa4e4..d346d60 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -125,6 +125,8 @@ gnome_pdf_viewer_SOURCES = \
gtkgesture.h \
page-control.c \
page-control.h \
+ pdf-properties-display.c \
+ pdf-properties-display.h \
$(BUILT_SOURCES)
# Font embedding hack for Gnome Print < 2.1.?2?
@@ -224,13 +226,11 @@ gpdf-marshal.c: gpdf-marshal.list $(GLIB_GENMARSHAL)
stockdir = $(datadir)/pixmaps/gpdf
stock_DATA = fitwidth.png
-ltk = \
- xpdf-flip.ltk \
- xpdf-top.ltk \
- xpdf.ltk
+gladedir = $(datadir)/gpdf/glade
+glade_DATA = \
+ gpdf-properties-dialog.glade
server_in_files = GNOME_PDF.server.in.in
-
serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)