Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMaciej Stachowiak <mstachow@src.gnome.org>2000-05-07 19:05:40 (GMT)
committer Maciej Stachowiak <mstachow@src.gnome.org>2000-05-07 19:05:40 (GMT)
commit9c4aa5453d1eaaa13eacb1d44e36c013be9cf3f9 (patch)
tree46ec5b24dfe0f9328bbbb3eb4f3564f790720a9d /pdf/xpdf/Makefile.am
parentca48d2651f141a7b3e451af043f12ef999c25995 (diff)
Work with OAF and fix various bugs:
* configure.in, aclocal.m4: Detect when Bonobo is built with OAF support, and if so use OAF. * xpdf/Makefile.am: When using OAF, link against OAF and install oafinfo file. * xpdf/gpdf.cc: Include oaf headers when using OAF. (openpdf): Use OAFIID to activate the component when using OAF. (container_set_view), (container_launch_component), (container_new): Put the view in an EventBox, not a ScrolledWindow; the component now handles scrolling itself. (key_press_event_cb): Removed; key press handling moved to component. (main): Initialize OAF instead of GOAD when using OAF. * xpdf/bonobo-application-x-pdf.cc: Include OAF headers when using OAF. (redraw_view): Handle the case where we are loading before the view is realized by connecting to the "realize" signal handler and deferring redrawing until then in that case. (real_redraw_view): Function to do the real redrawing. (load_pdf_from_stream): Don't call `realize_mainbox' directly, let `real_redraw_view' do it. (key_press_event_cb): In response to various key bindings, scroll the view, navigate pages, or zoom in/out. (button_press_event_cb): Grab the keyboard focus on a press of button 1. (view_create_menus): Rename menus to be more standard, and provide accelerators for menus and items. (realize_mainbox): Get window ourselves if we have to. (view_factory): Put the view in a scrolled window so scrolling can be handled by the component itself. Connect to "key_press" and "button_press" for keyboard and focus handling. Set the GTK_CAN_FOCUS flag for the main view widget. (init_bonobo_application_x_pdf_factory, init_server_factory): Use OAF when appropriate. * xpdf/application-x-pdf.oafinfo: New file, OAF activation record.
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am25
1 files changed, 20 insertions, 5 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index 9074ebc..3b2b9ae 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -1,3 +1,10 @@
+
+if USING_OAF
+OBJECT_DIRECTORY_LIBS=$(OAF_LIBS) $(GNOMEUI_LIBS)
+else
+OBJECT_DIRECTORY_LIBS=$(GNOMEGNORBA_LIBS)
+endif
+
INCLUDES = \
-I$(top_srcdir)/goo \
-I$(top_srcdir)/ltk \
@@ -70,7 +77,7 @@ gpdf_LDADD = \
$(GTK_LIBS) \
$(GNOME_LIBDIR) \
-lbonobo \
- $(GNOMEGNORBA_LIBS) \
+ $(OBJECT_DIRECTORY_LIBS) \
$(EXTRA_GNOME_LIBS) \
$(INTLLIBS)
@@ -90,7 +97,7 @@ bonobo_application_x_pdf_LDADD = \
$(GTK_LIBS) \
$(GNOME_LIBDIR) \
-lbonobo \
- $(GNOMEGNORBA_LIBS) \
+ $(OBJECT_DIRECTORY_LIBS) \
$(EXTRA_GLIB_LIBS) \
$(INTLLIBS)
@@ -162,8 +169,16 @@ ltk = \
xpdf-top.ltk \
xpdf.ltk
-gnorbadir = $(sysconfdir)/CORBA/servers
-gnorba_DATA = application-x-pdf.gnorba
+goaddir = $(sysconfdir)/CORBA/servers
+oafdir = $(datadir)/oaf
+
+if USING_OAF
+oaf_DATA = $(OAF_FILES)
+else
+goad_DATA = $(GOAD_FILES)
+endif
-EXTRA_DIST = $(bitmaps) ChangeLog $(ltk) $(gnorba_DATA) config.h
+GOAD_FILES = application-x-pdf.gnorba
+OAF_FILES = application-x-pdf.oafinfo
+EXTRA_DIST = $(bitmaps) ChangeLog $(ltk) $(GOAD_FILES) $(OAF_FILES) config.h