Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <mmeeks@src.gnome.org>1999-08-24 18:18:54 (GMT)
committer Michael Meeks <mmeeks@src.gnome.org>1999-08-24 18:18:54 (GMT)
commita8ffd9b6d2e0d6e0fbf851b4b0fe7acec67e72c1 (patch)
treeefda04d864d96515f28954f56e3a67a40208dc51 /pdf/xpdf/Makefile.am
parentae59cfdd10d16d5f360a97bf40f74e50ad998d92 (diff)
Added lock round XPDF global variable 'xref',
Fixed up some broken global CORBA things. Added thread support to autogen glib stuff.
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index b72a32a..f9cd918 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -1,8 +1,8 @@
-
-INCLUDES = \
- -I$(top_srcdir)/goo \
- -I$(top_srcdir)/ltk \
+INCLUDES = \
+ -I$(top_srcdir)/goo \
+ -I$(top_srcdir)/ltk \
-DGPDF_GLADE_DIR=\""$(gladedir)"\" \
+ $(EXTRA_GLIB_CFLAGS) \
$(EXTRA_GNOME_CFLAGS)
if WITH_GNOME
@@ -53,7 +53,6 @@ gpdf_LDADD = \
$(EXTRA_GNOME_LIBS) \
$(INTLLIBS)
-
bonobo_image_x_pdf_SOURCES = \
$(common_sources) \
BonoboStream.h \
@@ -61,15 +60,13 @@ bonobo_image_x_pdf_SOURCES = \
GOutputDev.cc \
bonobo-image-x-pdf.cc
-bonobo_image_x_pdf_CFLAGS = \
- -DBONOBO_IO
-
bonobo_image_x_pdf_LDADD = \
../goo/libgoo.a \
$(GTK_LIBS) \
$(GNOME_LIBDIR) \
-lbonobo \
$(GNOMEGNORBA_LIBS) \
+ $(EXTRA_GLIB_LIBS) \
$(INTLLIBS)
xpdf_SOURCES = \