Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <mmeeks@src.gnome.org>1999-08-11 18:20:31 (GMT)
committer Michael Meeks <mmeeks@src.gnome.org>1999-08-11 18:20:31 (GMT)
commite7fa464f61d0d442372b6096295d42a74e08c896 (patch)
tree0104ef97128da51214496a860a16bbe2f3fdc37d /pdf/xpdf/Makefile.am
parent7eaf5267dfdd4276c358facd9dc774f958327ca6 (diff)
Compiles at least :)
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index 6b5935b..6c6ceb0 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -4,14 +4,14 @@ INCLUDES = \
-I$(top_srcdir)/ltk \
-DGPDF_GLADE_DIR=\""$(gladedir)"\" \
$(EXTRA_GNOME_CFLAGS)
-
+
if WITH_GNOME
gui = gpdf
else
gui = xpdf
endif
-
-bin_PROGRAMS = pdftops pdftotext pdfinfo pdftopbm pdfimages $(gui)
+
+bin_PROGRAMS = pdftops pdftotext pdfinfo pdftopbm pdfimages $(gui) bonobo-image-x-pdf
common_sources = \
Array.cc \
@@ -49,6 +49,19 @@ gpdf_LDADD = \
$(EXTRA_GNOME_LIBS) \
../goo/libgoo.a
+bonobo_image_x_pdf_SOURCES = \
+ $(common_sources) \
+ GOutputDev.cc \
+ bonobo-image-x-pdf.cc
+
+bonobo_image_x_pdf_LDADD = \
+ ../goo/libgoo.a \
+ $(GTK_LIBS) \
+ $(GNOME_LIBDIR) \
+ -lbonobo \
+ $(GNOMEGNORBA_LIBS) \
+ $(INTLLIBS)
+
xpdf_SOURCES = \
$(common_sources) \
XOutputDev.cc \