Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-04 11:58:16 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-04 11:58:16 (GMT)
commit19be09f257f9250cb45fa96e05ab16d6e9ff7ba9 (patch)
treedfdad6d80601449e9100e423e9b92d8241ebcbf5 /shell/Makefile.am
parentb7abdba401b7aec50e93ecd1df1ce76cb1f315c1 (diff)
Split the properties pages in two different objects, depend only on the
2005-07-04 Marco Pesenti Gritti <mpg@redhat.com> * Makefile.am: * configure.ac: * data/evince-properties.glade: * properties/.cvsignore: * properties/Makefile.am: * properties/ev-properties-view.c: (ev_properties_view_dispose), (ev_properties_view_class_init), (ev_properties_view_format_date), (make_valid_utf8), (set_property), (ev_properties_view_set_info), (ev_properties_view_init), (ev_properties_view_new): * properties/ev-properties-view.h: * shell/Makefile.am: * shell/ev-properties-dialog.c: (ev_properties_dialog_class_init), (ev_properties_dialog_init), (ev_properties_dialog_set_document), (ev_properties_dialog_new): * shell/ev-properties-dialog.h: * shell/ev-properties-fonts.c: (ev_properties_fonts_dispose), (ev_properties_fonts_class_init), (ev_properties_fonts_init), (update_progress_label), (job_fonts_finished_cb), (ev_properties_fonts_set_document), (ev_properties_fonts_new): * shell/ev-properties-fonts.h: * shell/ev-properties.c: * shell/ev-properties.h: * shell/ev-window.c: (ev_window_setup_document), (ev_window_cmd_file_properties): Split the properties pages in two different objects, depend only on the backend where possible, use widgets instead of gobject for the glade part, reimplement the dialog itself with gtk. I need this to implement nautilus properties page.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 71faed5..e4010a9 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -10,6 +10,7 @@ INCLUDES= \
-I$(top_srcdir)/backend \
-I$(top_srcdir)/pdf \
-I$(top_srcdir)/pixbuf \
+ -I$(top_srcdir)/properties \
-I$(top_srcdir)/tiff \
-I$(top_srcdir)/ps \
-I$(top_srcdir)/djvu \
@@ -82,8 +83,10 @@ evince_SOURCES= \
ev-pixbuf-cache.h \
ev-print-job.c \
ev-print-job.h \
- ev-properties.c \
- ev-properties.h \
+ ev-properties-dialog.c \
+ ev-properties-dialog.h \
+ ev-properties-fonts.c \
+ ev-properties-fonts.h \
ev-utils.c \
ev-utils.h \
ev-view.c \
@@ -117,6 +120,7 @@ evince_LDADD= \
$(top_builddir)/cut-n-paste/zoom-control/libephymisc.la \
$(top_builddir)/cut-n-paste/zoom-control/libephywidgets.la \
$(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
+ $(top_builddir)/properties/libevproperties.la \
$(top_builddir)/lib/libev.la \
-ltiff -lz \
libevbackendfactory.la \