Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-02-08 12:48:04 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-02-08 12:48:04 (GMT)
commit1ae3aefb3948c59e79989a28797678dd985cd36a (patch)
treef7ddf5bee31041811297465aa7fb62fd694b7f40 /shell/Makefile.am
parent36c0e159a0421af3b2dfe0e700a75b899a475c2e (diff)
Remove libgnomeprint support. Fixes bug #512370.
2008-02-08 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * shell/Makefile.am: * shell/ev-application.[ch]: * shell/ev-sidebar-links.c: * shell/ev-utils.[ch]: * shell/ev-window.[ch]: Remove libgnomeprint support. Fixes bug #512370. svn path=/trunk/; revision=2895
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index b5883ed..f4b3e0a 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -11,9 +11,7 @@ INCLUDES= \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
$(SHELL_CFLAGS) \
$(WARN_CFLAGS) \
- $(DISABLE_DEPRECATED) \
- $(GNOME_PRINT_CFLAGS) \
- $(GTK_PRINT_CFLAGS)
+ $(DISABLE_DEPRECATED)
bin_PROGRAMS=evince
@@ -87,13 +85,6 @@ evince_SOURCES= \
ev-transition-animation.h \
main.c
-if WITH_GNOME_PRINT
-evince_SOURCES+= \
- ev-print-job.c \
- ev-print-job.h
-endif
-
-
evince_LDADD= \
$(top_builddir)/cut-n-paste/zoom-control/libephyzoom.la \
$(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
@@ -101,8 +92,7 @@ evince_LDADD= \
$(top_builddir)/cut-n-paste/gedit-message-area/libgeditmsgarea.la \
$(top_builddir)/properties/libevproperties.la \
$(top_builddir)/libdocument/libevbackend.la \
- $(SHELL_LIBS) \
- $(GNOME_PRINT_LIBS)
+ $(SHELL_LIBS)
BUILT_SOURCES = ev-marshal.h ev-marshal.c