Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-05 15:31:17 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-05 15:31:17 (GMT)
commit4684716c489657edf098565eb54bdf86bad1b45c (patch)
tree8e415778063a717a11dc09fa61042a603ff34b37 /shell/Makefile.am
parent26a8622fe284cd0e4531caa56f918d7cfaf8037b (diff)
Rework document types managing to avoid code duplication and actually
2005-07-05 Marco Pesenti Gritti <mpg@redhat.com> * backend/Makefile.am: * backend/ev-document-factory.c: (mime_type_supported_by_gdk_pixbuf), (ev_document_type_get_from_mime), (ev_document_factory_get_document), (ev_document_factory_get_backend), (ev_document_factory_get_mime_types), (ev_document_factory_get_all_mime_types): * backend/ev-document-factory.h: * shell/Makefile.am: * shell/ev-document-types.c: (get_document_from_uri), (ev_document_types_get_document), (file_filter_add_mime_list_and_free), (ev_document_types_add_filters): * shell/ev-document-types.h: * shell/ev-job-xfer.c: (ev_job_xfer_run): * shell/ev-properties-dialog.c: (ev_properties_dialog_set_document): * shell/ev-window.c: (ev_window_cmd_file_open), (ev_window_cmd_save_as): * thumbnailer/evince-thumbnailer.c: (evince_thumbnail_pngenc_get): Rework document types managing to avoid code duplication and actually abstract from backend implementations. Also provide a minimal factory api that can be used by thumbnailer/properties.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index e4010a9..7dc939f 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -8,13 +8,7 @@ INCLUDES= \
-I$(top_srcdir)/cut-n-paste/zoom-control/ \
-I$(top_srcdir)/cut-n-paste/toolbar-editor/ \
-I$(top_srcdir)/backend \
- -I$(top_srcdir)/pdf \
- -I$(top_srcdir)/pixbuf \
-I$(top_srcdir)/properties \
- -I$(top_srcdir)/tiff \
- -I$(top_srcdir)/ps \
- -I$(top_srcdir)/djvu \
- -I$(top_srcdir)/dvi \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
$(SHELL_CFLAGS) \