Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorJames Bowes <bowes@cs.dal.ca>2005-05-02 16:19:48 (GMT)
committer James Bowes <jbowes@src.gnome.org>2005-05-02 16:19:48 (GMT)
commit606f66cbbca54996a165121743cda6a993762c47 (patch)
treeaf9aeaf3c5f8b737c603576072e45503901ad434 /shell/Makefile.am
parent8ccbb218873ff3f7d5e6b924b9ff7d44f1f6d62e (diff)
Output zoom-control Makefile. build zoom-control subdir.
2005-05-02 James Bowes <bowes@cs.dal.ca> * configure.ac: Output zoom-control Makefile. * cut-n-paste/Makefile.am: build zoom-control subdir. * cut-n-paste/zoom-control/ephy-zoom-action.c: * cut-n-paste/zoom-control/ephy-zoom-action.h: * cut-n-paste/zoom-control/ephy-zoom-control.c: * cut-n-paste/zoom-control/ephy-zoom-control.h: * cut-n-paste/zoom-control/ephy-zoom.c: * cut-n-paste/zoom-control/ephy-zoom.h: New files imported from epiphany, and modified to add a separator into the menu. * cut-n-paste/zoom-control/Makefile.am: Build zoom-control. * data/evince-ui.xml: Replace old zoom toolbar actions with new zoom-control action. * shell/Makefile.am: Include zoom-control flags. * shell/ev-view.c: (ev_view_set_zoom), (ev_view_get_zoom), (ev_view_get_sizing_mode), (ev_view_zoom_in), (ev_view_zoom_out), (ev_view_zoom_for_size_presentation), (ev_view_zoom_for_size_continuous_and_dual_page), (ev_view_zoom_for_size_continuous), (ev_view_zoom_for_size_dual_page), (ev_view_zoom_for_size_single_page), (ev_view_zoom_normal): s/ev_view_zoom/ev_view_set_zoom/ and make public, add ev_view_get_zoom and ev_view_get_sizing_mode. * shell/ev-view.h: * shell/ev-window.c: (update_action_sensitivity), (update_sizing_buttons), (zoom_control_changed_cb), (register_custom_actions): Initialize and use the zoom-control widget.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index f9ef2f4..498be8a 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -5,6 +5,7 @@ INCLUDES= \
-DGNOMEDATADIR=\"$(datadir)\" \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/cut-n-paste/recent-files/ \
+ -I$(top_srcdir)/cut-n-paste/zoom-control/ \
-I$(top_srcdir)/backend \
-I$(top_srcdir)/pdf \
-I$(top_srcdir)/pixbuf \
@@ -80,11 +81,13 @@ evince_SOURCES= \
main.c \
$(NULL)
-evince_LDADD= \
- $(SHELL_LIBS) \
- $(top_builddir)/cut-n-paste/recent-files/librecent.la \
- $(top_builddir)/lib/libev.la \
- libevbackendfactory.la \
+evince_LDADD= \
+ $(SHELL_LIBS) \
+ $(top_builddir)/cut-n-paste/recent-files/librecent.la \
+ $(top_builddir)/cut-n-paste/zoom-control/libephymisc.la \
+ $(top_builddir)/cut-n-paste/zoom-control/libephywidgets.la \
+ $(top_builddir)/lib/libev.la \
+ libevbackendfactory.la \
$(NULL)
BUILT_SOURCES = ev-marshal.h ev-marshal.c