Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-01-18 11:53:54 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2009-01-18 11:53:54 (GMT)
commit68d0fc3c59185065d9694ba3f8cb2665b984eb9f (patch)
tree1c3495114d26e1b9d201c557c351d5cf3996f925 /shell/Makefile.am
parent51e1ae36121928f84940b8e8dcb317f87157933b (diff)
Move EvView specific code to a libeviview library so that it can be
2009-01-18 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * Makefile.am: * libdocument/Makefile.am: * libview/Makefile.am: * libview/ev-job-scheduler.[ch]: * libview/ev-jobs.[ch]: * libview/ev-page-cache.[ch]: * libview/ev-pixbuf-cache.[ch]: * libview/ev-timeline.[ch]: * libview/ev-transition-animation.[ch]: * libview/ev-view-accessible.[ch]: * libview/ev-view-marshal.list: * libview/ev-view.[ch]: * shell/Makefile.am: Move EvView specific code to a libeviview library so that it can be embbeded in other applications. Based on patches by Tomeu Vizoso. Fixes bug #567751. svn path=/trunk/; revision=3348
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am19
1 files changed, 2 insertions, 17 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d5abcb0..ab09ef9 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -9,6 +9,7 @@ INCLUDES= \
-I$(top_srcdir)/cut-n-paste/evmountoperation/ \
-I$(top_srcdir)/cut-n-paste/smclient/ \
-I$(top_srcdir)/libdocument \
+ -I$(top_srcdir)/libview \
-I$(top_srcdir)/properties \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
@@ -30,10 +31,6 @@ evince_SOURCES= \
eggfindbar.h \
ev-application.c \
ev-application.h \
- ev-job-scheduler.h \
- ev-job-scheduler.c \
- ev-jobs.h \
- ev-jobs.c \
ev-file-monitor.h \
ev-file-monitor.c \
ev-history.c \
@@ -55,12 +52,8 @@ evince_SOURCES= \
ev-page-action.h \
ev-page-action-widget.c \
ev-page-action-widget.h \
- ev-page-cache.h \
- ev-page-cache.c \
ev-password-view.h \
ev-password-view.c \
- ev-pixbuf-cache.c \
- ev-pixbuf-cache.h \
ev-print-operation.h \
ev-print-operation.c \
ev-progress-message-area.h \
@@ -73,11 +66,6 @@ evince_SOURCES= \
ev-open-recent-action.h \
ev-utils.c \
ev-utils.h \
- ev-view-accessible.c \
- ev-view-accessible.h \
- ev-view-private.h \
- ev-view.c \
- ev-view.h \
ev-window.c \
ev-window.h \
ev-window-title.c \
@@ -96,10 +84,6 @@ evince_SOURCES= \
ev-sidebar-thumbnails.h \
ev-stock-icons.c \
ev-stock-icons.h \
- ev-timeline.c \
- ev-timeline.h \
- ev-transition-animation.c \
- ev-transition-animation.h \
main.c
evince_LDADD= \
@@ -112,6 +96,7 @@ evince_LDADD= \
$(top_builddir)/cut-n-paste/smclient/libsmclient.la \
$(top_builddir)/properties/libevproperties.la \
$(top_builddir)/libdocument/libevbackend.la \
+ $(top_builddir)/libview/libevview.la \
$(SHELL_LIBS)
BUILT_SOURCES = ev-marshal.h ev-marshal.c