Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@gnome.org>2004-12-22 17:20:51 (GMT)
committer Anders Carlsson <andersca@src.gnome.org>2004-12-22 17:20:51 (GMT)
commit809ca307a8b35886451648e3ae7d794a2a20c63e (patch)
treea48805304c801665a9b456e1114dd28d1f0fa734 /shell/Makefile.am
parent8e30e595ac2d7f976bfab060dbc03595358431fb (diff)
Add pixbuf backend.
2004-12-22 Anders Carlsson <andersca@gnome.org> * Makefile.am: * configure.ac: * pixbuf/Makefile.am: * pixbuf/pixbuf-document.c: (G_DEFINE_TYPE_WITH_CODE), (pixbuf_document_load), (pixbuf_document_get_n_pages), (pixbuf_document_set_page), (pixbuf_document_get_page), (pixbuf_document_set_target), (pixbuf_document_set_scale), (pixbuf_document_set_page_offset), (pixbuf_document_get_page_size), (pixbuf_document_render), (pixbuf_document_begin_find), (pixbuf_document_end_find), (pixbuf_document_finalize), (pixbuf_document_class_init), (pixbuf_document_document_iface_init), (pixbuf_document_init): * pixbuf/pixbuf-document.h: * shell/Makefile.am: * shell/ev-application.c: (ev_application_open): * shell/ev-window.c: (mime_type_supported_by_gdk_pixbuf), (ev_window_open): Add pixbuf backend.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d51abd1..a36511a 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -5,6 +5,7 @@ INCLUDES= \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/backend \
-I$(top_srcdir)/pdf/xpdf \
+ -I$(top_srcdir)/pixbuf \
-I$(top_srcdir)/ps \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
@@ -41,6 +42,7 @@ evince_LDADD= \
$(SHELL_LIBS) \
$(top_builddir)/backend/libevbackend.la \
$(top_builddir)/pdf/xpdf/libpdfdocument.la \
+ $(top_builddir)/pixbuf/libpixbufdocument.la \
$(top_builddir)/ps/libgtkgs.la \
$(NULL)