Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-02-10 04:36:12 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-02-10 04:36:12 (GMT)
commitf2511820a5499da40ae972bc833616a176d78f8f (patch)
tree3397621dd1267eb8d899cd52e08e0f3ba55d06cb /shell/Makefile.am
parentfb037eb2a0842976deddd8df6793ed642eea5674 (diff)
Make printing support optional. Patch from Eduardo de Barros Lima
* configure.ac: * shell/Makefile.am: * shell/ev-sidebar-links.c: (print_section_cb): * shell/ev-utils.c: * shell/ev-utils.h: * shell/ev-window.c: (update_action_sensitivity), (ev_window_close_dialogs), (ev_window_print): * shell/ev-window.h: Make printing support optional. Patch from Eduardo de Barros Lima <eduardo.lima@indt.org.br> for the bug #330546.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 0fed805..26b195e 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -10,7 +10,8 @@ INCLUDES= \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
$(SHELL_CFLAGS) \
- $(WARN_CFLAGS)
+ $(WARN_CFLAGS) \
+ $(GNOME_PRINT_CFLAGS)
bin_PROGRAMS=evince
@@ -41,8 +42,6 @@ evince_SOURCES= \
ev-password-view.c \
ev-pixbuf-cache.c \
ev-pixbuf-cache.h \
- ev-print-job.c \
- ev-print-job.h \
ev-properties-dialog.c \
ev-properties-dialog.h \
ev-properties-fonts.c \
@@ -70,13 +69,21 @@ evince_SOURCES= \
ev-stock-icons.h \
main.c
+if WITH_GNOME_PRINT
+evince_SOURCES+= \
+ ev-print-job.c \
+ ev-print-job.h
+endif
+
+
evince_LDADD= \
$(top_builddir)/cut-n-paste/recent-files/librecent.la \
$(top_builddir)/cut-n-paste/zoom-control/libephyzoom.la \
$(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
$(top_builddir)/properties/libevproperties.la \
- $(top_builddir)/lib/libev.la \
- $(SHELL_LIBS)
+ $(top_builddir)/lib/libev.la \
+ $(SHELL_LIBS) \
+ $(GNOME_PRINT_LIBS)
BUILT_SOURCES = ev-marshal.h ev-marshal.c