Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-10-11 09:35:12 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2009-10-11 14:33:42 (GMT)
commitf2952fb9e45b33d166bd256c80199d1236fc99bc (patch)
treea3b808e61e9e5a898ac8715472f4b5dc9d91f9c0 /shell/Makefile.am
parent11c7e9cd813ef98cc4d4fc744a03bc6ea964adec (diff)
[metadata] Add evince-convert-metadata tool
It converts the old xml based metadata file into gvfs metadata.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 4553348..a8acf73 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -24,6 +24,8 @@ INCLUDES= \
bin_PROGRAMS=evince
+libexec_PROGRAMS=evince-convert-metadata
+
EV_MEDIA_PLAYER_KEYS_SOURCES = ev-media-player-keys.c ev-media-player-keys.h
if ENABLE_DBUS
DBUS_SOURCES = $(EV_MEDIA_PLAYER_KEYS_SOURCES)
@@ -110,6 +112,14 @@ if ENABLE_DBUS
BUILT_SOURCES += ev-application-service.h
endif
+evince_convert_metadata_SOURCES= \
+ ev-convert-metadata.c
+
+evince_convert_metadata_LDADD= \
+ $(SHELL_LIBS)
+
+
+
EXTRA_DIST = ev-marshal.list \
ev-application-service.xml \
$(EV_MEDIA_PLAYER_KEYS_SOURCES)