Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorDavid Malcolm <dmalcolm@redhat.com>2005-04-18 20:37:04 (GMT)
committer David Malcolm <dave_malcolm@src.gnome.org>2005-04-18 20:37:04 (GMT)
commitf332d42bc834d6a7b0ec58bb8e073e63bc619f63 (patch)
treecccfc8a309b52f379be170146673cbfa5fd5b678 /shell/Makefile.am
parent594edf9b1277d5ec88892c2ea02c2bdc2f2e8b0e (diff)
New files, handling the mapping from mimetypes to backends
2005-04-18 David Malcolm <dmalcolm@redhat.com> * shell/ev-document-types.h: * shell/ev-document-types.c: New files, handling the mapping from mimetypes to backends * shell/ev-window.c: * thumbnailer/evince-thumbnailer.c: Use the ev-document-types code * shell/Makefile.am: Added new convenience library libevbackendfactory_la, containing the new mimetype->backend logic; moved the backends into it. * thumbnailer/Makefile.am: Make the thumbnailer link with the libevbackend.la convenience library, rather than having a duplicate of the backend logic here.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am45
1 files changed, 29 insertions, 16 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 629e89d..95dcf83 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -18,6 +18,34 @@ INCLUDES= \
$(NULL)
bin_PROGRAMS=evince
+noinst_LTLIBRARIES = libevbackendfactory.la
+
+libevbackendfactory_la_SOURCES= \
+ ev-document-types.c \
+ ev-document-types.h
+
+libevbackendfactory_la_LIBADD = \
+ $(top_builddir)/pdf/libpdfdocument.la \
+ $(top_builddir)/pixbuf/libpixbufdocument.la \
+ $(top_builddir)/ps/libgtkgs.la \
+ $(top_builddir)/backend/libevbackend.la \
+ $(NULL)
+
+if ENABLE_DJVU
+libevbackendfactory_la_LIBADD += \
+ $(top_builddir)/djvu/libgtkdjvu.la \
+ $(NULL)
+endif
+
+if ENABLE_DVI
+libevbackendfactory_la_LIBADD += \
+ $(top_builddir)/dvi/libgtkdvi.la \
+ $(NULL)
+endif
+
+if WITH_TYPE1_FONTS
+libevbackendfactory_la_LIBADD += -lt1lib
+endif
evince_SOURCES= \
dummy.cc \
@@ -58,23 +86,8 @@ evince_LDADD= \
$(SHELL_LIBS) \
$(top_builddir)/cut-n-paste/recent-files/librecent.la \
$(top_builddir)/lib/libev.la \
- $(top_builddir)/pdf/libpdfdocument.la \
- $(top_builddir)/pixbuf/libpixbufdocument.la \
- $(top_builddir)/ps/libgtkgs.la \
- $(top_builddir)/backend/libevbackend.la \
- $(NULL)
-
-if ENABLE_DJVU
-evince_LDADD += \
- $(top_builddir)/djvu/libgtkdjvu.la \
+ libevbackendfactory.la \
$(NULL)
-endif
-
-if ENABLE_DVI
-evince_LDADD += \
- $(top_builddir)/dvi/libgtkdvi.la \
- $(NULL)
-endif
BUILT_SOURCES = ev-marshal.h ev-marshal.c