Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2004-12-22 02:19:48 (GMT)
committer Owen Taylor <otaylor@src.gnome.org>2004-12-22 02:19:48 (GMT)
commitff8d0330fc705c931a40d07e28eb4060f1dd92f9 (patch)
tree386af38110a5d9e9b7f8ede9b17aa92947955971 /shell/Makefile.am
parent1d8612cf9fa4348ad27e06b38d9c21d38d31c94a (diff)
Start of content-area widget.
Tue Dec 21 21:07:55 2004 Owen Taylor <otaylor@redhat.com> * shell/ev-view.[ch]: Start of content-area widget. * shell/ev-window.c: Create a EvView, update it as we change documents. * shell/Makefile.am shell/ev-marshal.list: Add generated marshalers.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 891eadb..e764e3a 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -17,6 +17,10 @@ evince_SOURCES= \
eggfindbar.h \
ev-application.c \
ev-application.h \
+ ev-marshal.c \
+ ev-marshal.h \
+ ev-view.c \
+ ev-view.h \
ev-window.c \
ev-window.h \
ev-sidebar.c \
@@ -29,3 +33,14 @@ evince_LDADD= \
$(top_builddir)/backend/libevbackend.la \
$(top_builddir)/pdf/xpdf/libpdfdocument.la \
$(NULL)
+
+BUILT_SOURCES = ev-marshal.h ev-marshal.c
+
+EXTRA_DIST = ev-marshal.list
+
+ev-marshal.h: ev-marshal.list
+ glib-genmarshal --prefix=ev_marshal ev-marshal.list --header > ev-marshal.h
+
+ev-marshal.c: ev-marshal.list
+ echo '#include "ev-marshal.h"' > ev-marshal.c
+ glib-genmarshal --prefix=ev_marshal ev-marshal.list --body >> ev-marshal.c