Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/smclient/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cut-n-paste/smclient/Makefile.am')
-rw-r--r--cut-n-paste/smclient/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/cut-n-paste/smclient/Makefile.am b/cut-n-paste/smclient/Makefile.am
index c4ed73a..7cc76bc 100644
--- a/cut-n-paste/smclient/Makefile.am
+++ b/cut-n-paste/smclient/Makefile.am
@@ -1,20 +1,36 @@
noinst_LTLIBRARIES = libsmclient.la
-libsmclient_la_SOURCES = \
+if PLATFORM_WIN32
+platform_sources = eggsmclient-win32.c
+else
+platform_libs = -lSM -lICE
+platform_sources = \
+ eggsmclient-xsmp.c \
eggdesktopfile.c \
- eggdesktopfile.h \
+ eggdesktopfile.h
+platform_defines = -DEGG_SM_CLIENT_BACKEND_XSMP
+endif
+
+libsmclient_la_SOURCES = \
eggsmclient.c \
eggsmclient.h \
eggsmclient-private.h \
- eggsmclient-xsmp.c
+ $(platform_sources)
libsmclient_la_CFLAGS = \
-DG_LOG_DOMAIN=\""EggSMClient"\" \
- -DEGG_SM_CLIENT_BACKEND_XSMP \
+ $(platform_defines) \
$(SMCLIENT_CFLAGS) \
$(WARNING_CFLAGS) \
$(DISABLE_DEPRECATED)
libsmclient_la_LIBADD = \
$(SMCLIENT_LIBS) \
- -lSM -lICE
+ $(platform_libs)
+
+EXTRA_DIST = \
+ eggsmclient-win32.c \
+ eggsmclient-xsmp.c \
+ eggdesktopfile.c \
+ eggdesktopfile.h
+