Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 54229ee..30bc0af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,19 @@
-SUBDIRS = src
+SUBDIRS = src
+bin_SCRIPTS = fsgateway
+EXTRA_DIST = fsgateway.in
+
+REWRITE = \
+ sed -e "s|\@prefix\@|$(prefix)|g" \
+ -e "s|\@pkglibdir\@|$(pkglibdir)|g" \
+ -e "s|\@bindir\@|$(bindir)|g" \
+ -e "s|\@MONO\@|$(MONO)|g"
+
+$(bin_SCRIPTS): $(srcdir)/fsgateway.in Makefile
+ $(REWRITE) $(srcdir)/fsgateway.in > $@.tmp
+ mv $@.tmp $@
+
+CLEANFILES = \
+ fsgateway
MAINTAINERCLEANFILES = \
INSTALL \