Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-26 10:06:54 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-26 10:06:54 (GMT)
commit16756441cf594664f10460f6fa82f9ab969ebeda (patch)
treef282962b2f9f182c47b48295d635c9e103b8acaf /Makefile.am
parent1d6200fbfca73bd3e048e6b388927f50e977ec2d (diff)
small fix for GNUstep compatibility
svn path=/trunk/; revision=2551
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d6047d..245f6b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,12 +187,14 @@ endif
$(INSTALL) $(top_srcdir)/macosx/Info.plist $(BUNDLE_RESOURCES_DIR)/
$(INSTALL) $(top_srcdir)/macosx/gcompris.svg $(BUNDLE_RESOURCES_DIR)/
$(INSTALL) $(top_srcdir)/macosx/gcompris.png $(BUNDLE_RESOURCES_DIR)/
+if OS_MACOSX
$(FCT_OTOOL_CP) ; for s in $$(find $(BUNDLE_EXEC_DIR)$(NSBUNDLE_GTK_DIR)/ -name '*.so') ; do \
otool_cp $$s $(prefix) $(BUNDLE_EXEC_DIR)$(NSBUNDLE_GTK_DIR) $(NSBUNDLE_GTK_DIR) ; \
done
$(FCT_OTOOL_CP) ; for s in $$(find $(BUNDLE_RESOURCES_DIR) -name '*.so') ; do \
otool_cp $$s $(prefix) $(BUNDLE_EXEC_DIR)$(NSBUNDLE_GTK_DIR) $(NSBUNDLE_GTK_DIR) ; \
- done
+ done
+endif
endif