Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2005-12-19 22:24:28 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2005-12-19 22:24:28 (GMT)
commit4208cfa0162f433ef17f289c6568f19648341fd9 (patch)
treea0ab0491e4c90f5ec285a957b75247e4fddbbeec /Makefile.am
parenta8b3a8f9d2b01ce8e17747a145048fb0247a48ad (diff)
- Patch by Patrick GOLDBRONN pgoldbronn on free.fr
Support out of dir compilation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 18c05e4..074ba51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,15 +34,15 @@ distcore = $(PACKAGE)-core-$(VERSION)
install-data-local:
@$(NORMAL_INSTALL)
- if test -d @PACKAGE_DATA_DIR@; then \
- $(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@; \
- cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude "Makefile.in" --exclude "*.in" --exclude "*~" --exclude "Makefile" --exclude "Makefile.am" --exclude CVS --exclude .xvpics --exclude "*.assetml" * | ( cd $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
+ if test -d $(srcdir)/$(PACKAGE_DATA_DIR); then \
+ $(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR); \
+ cd $(srcdir)/$(PACKAGE_DATA_DIR) ; tar cf - --exclude "Makefile.in" --exclude "*.in" --exclude "*~" --exclude "Makefile" --exclude "Makefile.am" --exclude CVS --exclude .xvpics --exclude "*.assetml" * | ( cd $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR) ; tar xf -) ; cd .. ; \
fi
dist-hook:
- if test -d @PACKAGE_DATA_DIR@; then \
- $(mkinstalldirs) $(distdir)/@PACKAGE_DATA_DIR@; \
- cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude "Makefile.in" --exclude "Makefile" --exclude "*~" --exclude ".*" --exclude CVS --exclude .xvpics * | ( cd ../$(distdir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
+ if test -d $(PACKAGE_DATA_DIR); then \
+ $(mkinstalldirs) $(distdir)/$(PACKAGE_DATA_DIR); \
+ cd $(srcdir)/$(PACKAGE_DATA_DIR) ; tar cf - --exclude "Makefile.in" --exclude "Makefile" --exclude "*~" --exclude ".*" --exclude CVS --exclude .xvpics * | ( cd ../$(distdir)/$(PACKAGE_DATA_DIR) ; tar xf -) ; cd .. ; \
fi