Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-22 13:02:00 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-22 13:02:00 (GMT)
commit5aab6396aee5dc1e7059726c77a679bbfbb4ebdd (patch)
treeba18b88ca47e805b826b88cbf4c53b4071ec31c5 /Makefile.am
parentb17ea5076d4bf734ac53ad699ba47de4ff94b724 (diff)
reloc gtk libs for osx bundle. TODO: fix for no osx.
svn path=/trunk/; revision=2536
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 654f3e9..f12afbd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,17 +101,20 @@ BUNDLE_EXEC_DIR=$(BUNDLE_APPDIR)
endif
if WITH_NSBUNDLE
-nsbundle:
+nsbundle:
$(INSTALL) -d $(BUNDLE_RESOURCES_DIR)
$(INSTALL) -d $(BUNDLE_EXEC_DIR)
-
+ $(INSTALL) -d $(BUNDLE_EXEC_DIR)/$(NSBUNDLE_GTK_DIR)
make install prefix=$(BUNDLE_RESOURCES_DIR) \
exec_prefix=$(BUNDLE_RESOURCES_DIR) \
bindir=$(BUNDLE_EXEC_DIR) \
PYTHON_PLUGIN_DIR=$(BUNDLE_RESOURCES_DIR)/share/gcompris/python
-
mv $(BUNDLE_EXEC_DIR)/gcompris $(BUNDLE_EXEC_DIR)/$(BUNDLE_NAME)
-# check info.plist instead.
+ for f in $$(otool -L $(BUNDLE_EXEC_DIR)/$(BUNDLE_NAME) | grep $(prefix) | sed -e 's,^.*$(prefix)/\(.*.dylib\).*$$,\1,' ); do \
+ ls -L $(prefix)/$$f; \
+ cp -Lv $(prefix)/$$f $(BUNDLE_EXEC_DIR)/$(NSBUNDLE_GTK_DIR)/$f ;\
+ install_name_tool -change $(prefix)/$$f @executable_path/$(NSBUNDLE_GTK_DIR)/$$f $(BUNDLE_EXEC_DIR)/$(BUNDLE_NAME) ; \
+ done;
endif