Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2002-02-10 22:13:30 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2002-02-10 22:13:30 (GMT)
commit6728d32882a4f53e543cb021ca5bc1c1247054f7 (patch)
treea8eca5250b9e0dfe6d6f18b2cdfc6629561f5025 /Makefile.am
parentf4e6ad19181cd6da9797d20cd83c31e06613cfcf (diff)
mane changes / see changlog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 19 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 02bb1da..e2c3bc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,11 +24,14 @@ EXTRA_DIST = \
intltool-merge.in \
intltool-update.in
+distcore = $(PACKAGE)-core-$(VERSION)
+
install-data-local:
@$(NORMAL_INSTALL)
if test -d @PACKAGE_DATA_DIR@; then \
$(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@; \
- find @PACKAGE_DATA_DIR@ -name \*~ -or -name \*.in -printf \"%f\n\" >/tmp/GCOMPRIS_LIST.txt ; \
+ find @PACKAGE_DATA_DIR@ -name \*~ -printf %f\\n >/tmp/GCOMPRIS_LIST.txt ; \
+ find @PACKAGE_DATA_DIR@ -name \*.in -printf %f\\n >>/tmp/GCOMPRIS_LIST.txt ; \
cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude CVS --exclude .xvpics --exclude-from /tmp/GCOMPRIS_LIST.txt * | ( cd $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
rm -f /tmp/GCOMPRIS_LIST.txt ; \
fi
@@ -36,11 +39,24 @@ install-data-local:
dist-hook:
if test -d @PACKAGE_DATA_DIR@; then \
$(mkinstalldirs) $(distdir)/@PACKAGE_DATA_DIR@; \
- find @PACKAGE_DATA_DIR@ -name \*~ -printf \"%f\n\" >/tmp/GCOMPRIS_LIST.txt ; \
+ find @PACKAGE_DATA_DIR@ -name \*~ -printf %f\\n >/tmp/GCOMPRIS_LIST.txt ; \
+ find @PACKAGE_DATA_DIR@ -name \.\* -printf %f\\n >>/tmp/GCOMPRIS_LIST.txt ; \
cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude CVS --exclude .xvpics --exclude-from /tmp/GCOMPRIS_LIST.txt * | ( cd ../$(distdir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
- rm -f /tmp/GCOMPRIS_LIST.txt ; \
fi
+# rm -f /tmp/GCOMPRIS_LIST.txt ; \
clean-local:
rm -f intltool-extract intltool-merge intltool-update
+
+# Creates separates distribution files for the sounds by locale
+dist-sounds:
+ ./create_dist_sounds en @ALL_LINGUAS@
+
+# Create a core dist file without localized sounds file
+dist-core:
+ cp $(distdir).tar.gz $(distcore).tar.gz
+ gzip -df $(distcore).tar.gz
+ tar f $(distcore).tar --delete $(distdir)/boards/sounds
+ gzip --best $(distcore).tar
+ @echo Created $(distcore).tar.gz