Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-18 23:40:48 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-18 23:40:48 (GMT)
commita4eb402c316529c7cb183a7c08706c21a0aa3179 (patch)
tree5ca6f4cb474faa6f868b3206a40c6abdcfb55744 /Makefile.am
parent8900980775782ebf5bc4bed75e463ff0e83969d9 (diff)
NSBundle usage for reloc
Bundle construction svn path=/trunk/; revision=2525
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 600e82f..654f3e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,6 +73,7 @@ CLEANFILES = core-translation-report gcompris.desktop gcompris-edit.desktop gcom
clean-local:
rm -f intltool-extract intltool-merge intltool-update
+ -rm -fr $(BUNDLE_APPDIR)
# Creates separates distribution files for the sounds by locale
dist-sounds:
@@ -90,3 +91,27 @@ all-local:
ACLOCAL_AMFLAGS =
+
+if OS_MACOSX
+BUNDLE_RESOURCES_DIR=$(BUNDLE_APPDIR)/Contents/Resources
+BUNDLE_EXEC_DIR=$(BUNDLE_APPDIR)/Contents/MacOS
+else
+BUNDLE_RESOURCES_DIR=$(BUNDLE_APPDIR)/Resources
+BUNDLE_EXEC_DIR=$(BUNDLE_APPDIR)
+endif
+
+if WITH_NSBUNDLE
+nsbundle:
+ $(INSTALL) -d $(BUNDLE_RESOURCES_DIR)
+ $(INSTALL) -d $(BUNDLE_EXEC_DIR)
+
+ make install prefix=$(BUNDLE_RESOURCES_DIR) \
+ exec_prefix=$(BUNDLE_RESOURCES_DIR) \
+ bindir=$(BUNDLE_EXEC_DIR) \
+ PYTHON_PLUGIN_DIR=$(BUNDLE_RESOURCES_DIR)/share/gcompris/python
+
+ mv $(BUNDLE_EXEC_DIR)/gcompris $(BUNDLE_EXEC_DIR)/$(BUNDLE_NAME)
+# check info.plist instead.
+endif
+
+