Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2007-08-30 23:30:52 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2007-08-30 23:30:52 (GMT)
commitb1f0cb2ebe48546cf96d2367184728af0e1f9bac (patch)
tree0a48206124d5e2d73c79dcf73593a1e2c9a611eb /Makefile.am
parent2ace1e405e664ea889776626947d51dc28ee61f7 (diff)
Fixed bug#327462 : Please move data files into a separate CVS module
Now all voices are in a separated svn module. The voices must now be put under boards/voices/<locale> instead of boards/sounds/<locale> To get the voices installed in the proper place, simply run: make update-voices svn path=/trunk/; revision=2944
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 0293d92..cbd217b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,7 +65,7 @@ install-data-local:
@$(NORMAL_INSTALL)
if test -d $(srcdir)/$(PACKAGE_DATA_DIR); then \
$(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR); \
- cd $(srcdir)/$(PACKAGE_DATA_DIR) ; tar cf - --exclude "Makefile.in" --exclude "*.in" --exclude "*~" --exclude "Makefile" --exclude "Makefile.am" --exclude .svn --exclude .xvpics --exclude "1[1-9].ogg" --exclude "2?.ogg" * | ( cd $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR) ; tar xf -) ; cd .. ; \
+ cd $(srcdir)/$(PACKAGE_DATA_DIR) ; tar cf - --exclude "Makefile.in" --exclude "*.in" --exclude "*~" --exclude "Makefile" --exclude "Makefile.am" --exclude .svn --exclude "1[1-9].ogg" --exclude "2?.ogg" * | ( cd $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR) ; tar xf -) ; cd .. ; \
fi
dist-hook:
@@ -81,17 +81,13 @@ clean-local:
rm -f intltool-extract intltool-merge intltool-update
-rm -fr $(BUNDLE_APPDIR)
-# Creates separates distribution files for the sounds by locale
-dist-sounds:
- ./create_dist_sounds en @ALL_LINGUAS@
-
-# Create a core dist file without localized sounds file
-dist-core:
- cp $(distdir).tar.gz $(distcore).tar.gz
- gzip -df $(distcore).tar.gz
- tar f $(distcore).tar --delete $(distdir)/boards/sounds
- gzip --best $(distcore).tar
- @echo Created $(distcore).tar.gz
+update-voices:
+ @if test -d $(PACKAGE_DATA_DIR)/voices; then \
+ svn up $(PACKAGE_DATA_DIR)/voices; \
+ else \
+ mkdir $(PACKAGE_DATA_DIR)/voices; \
+ svn co svn+ssh://bcoudoin@svn.gnome.org/svn/gcompris/voices $(PACKAGE_DATA_DIR)/voices; \
+ fi
all-local: