Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2003-02-05 14:01:53 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2003-02-05 14:01:53 (GMT)
commitb724521c027c723e1b4e097f4853c39341749187 (patch)
tree17490bb4dd708088ed7b3a7daa5470a9e2734677 /Makefile.am
parent0c96311a93296a4ca90c98b985874526d72cb0b9 (diff)
added po stats
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dbc4c2d..4b45435 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,8 @@ EXTRA_DIST = config.rpath \
gcompris.spec \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in
+ intltool-update.in \
+ core-translation-report po-checktrans.py po-checktrans
distcore = $(PACKAGE)-core-$(VERSION)
@@ -41,6 +42,8 @@ dist-hook:
fi
+CLEANFILES = core-translation-report gcompris.desktop
+
clean-local:
rm -f intltool-extract intltool-merge intltool-update
@@ -56,4 +59,11 @@ dist-core:
gzip --best $(distcore).tar
@echo Created $(distcore).tar.gz
+# Display stats on translation
+core-translation-report: po/gcompris.pot po-checktrans.py po-checktrans
+ -(cd $(srcdir) && ./po-checktrans po/gcompris.pot po/*.po)
+
+all-local: core-translation-report
+
+
ACLOCAL_AMFLAGS =