Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2001-10-29 16:52:36 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2001-10-29 16:52:36 (GMT)
commitd92388b1112f5779e1bb7fd14cf9f6eaf7db455b (patch)
tree6b987fe1f6a239c851b7f1b9750a028911ff6e13 /Makefile.am
Initial revision
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ab18b67
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,39 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = intl po macros src sounds docs boards
+
+icondir=$(datadir)/pixmaps
+icon_DATA = gcompris.png
+
+Gamesdir=$(datadir)/gnome/apps/Games
+Games_in_files = gcompris.desktop.in
+Games_DATA = $(Games_in_files:.desktop.in=.desktop)
+@XML_I18N_MERGE_DESKTOP_RULE@
+
+Menudir=$(prefix)/lib/menu
+Menu_DATA=gcompris
+
+EXTRA_DIST = \
+ $(Games_DATA) \
+ $(icon_DATA) \
+ $(Menu_DATA) \
+ gcompris.spec.in \
+ gcompris.spec \
+ xml-i18n-extract.in \
+ xml-i18n-merge.in \
+ xml-i18n-update.in
+
+install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d @PACKAGE_DATA_DIR@; then \
+ $(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@; \
+ cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude CVS --exclude .xvpics * | ( cd $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
+ fi
+
+dist-hook:
+ if test -d @PACKAGE_DATA_DIR@; then \
+ $(mkinstalldirs) $(distdir)/@PACKAGE_DATA_DIR@; \
+ cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude CVS --exclude .xvpics * | ( cd ../$(distdir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
+ fi
+
+