Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2002-03-29 13:31:41 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2002-03-29 13:31:41 (GMT)
commitdadbc91c8fa891c525b5ce2771e8e27389d78b54 (patch)
tree7896fdb922b47f840a393f0e6cae14163fa7b080 /Makefile.am
parent065da408be4a729ed2dd85edb2a59f1df981b52b (diff)
changed for BSD
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index f2e33a3..b5c0176 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = intl po macros src sounds docs boards
+SUBDIRS = intl po src sounds docs boards
icondir=$(datadir)/pixmaps
icon_DATA = gcompris.png
@@ -31,18 +31,14 @@ install-data-local:
@$(NORMAL_INSTALL)
if test -d @PACKAGE_DATA_DIR@; then \
$(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@; \
- find @PACKAGE_DATA_DIR@ -name \*~ -printf %f\\n >/tmp/GCOMPRIS_LIST.txt ; \
- find @PACKAGE_DATA_DIR@ -name \*.in -printf %f\\n >>/tmp/GCOMPRIS_LIST.txt ; \
- cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude CVS --exclude .xvpics --exclude-from /tmp/GCOMPRIS_LIST.txt * | ( cd $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
+ cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude "*.in" --exclude "*~" --exclude CVS --exclude .xvpics * | ( cd $(DESTDIR)/$(pkgdatadir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
rm -f /tmp/GCOMPRIS_LIST.txt ; \
fi
dist-hook:
if test -d @PACKAGE_DATA_DIR@; then \
$(mkinstalldirs) $(distdir)/@PACKAGE_DATA_DIR@; \
- find @PACKAGE_DATA_DIR@ -name \*~ -printf %f\\n >/tmp/GCOMPRIS_LIST.txt ; \
- find @PACKAGE_DATA_DIR@ -name \.\* -printf %f\\n >>/tmp/GCOMPRIS_LIST.txt ; \
- cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude CVS --exclude .xvpics --exclude-from /tmp/GCOMPRIS_LIST.txt * | ( cd ../$(distdir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
+ cd @PACKAGE_DATA_DIR@ ; tar cf - --exclude "*~" --exclude ".*" --exclude CVS --exclude .xvpics * | ( cd ../$(distdir)/@PACKAGE_DATA_DIR@ ; tar xf -) ; cd .. ; \
rm -f /tmp/GCOMPRIS_LIST.txt ; \
fi