Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2008-10-28 23:07:09 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2008-10-28 23:07:09 (GMT)
commitfa7c41fc95f82853f3c3fb43dd33703ba996b882 (patch)
tree55e1e11ffaeeea5489d8df29aa3164f0bea3c476 /Makefile.am
parentcaa59c5d23d1e98805857ed18e747e2484cb910d (diff)
configure fixes and cleanup by Yavor Doganov.
It is no more needed to copy config.rpath localy. svn path=/trunk/; revision=3586
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 06c410a..4506c54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,16 +57,18 @@ EXTRA_DIST = \
config.h.mingw.in Makefile.mingw.in global_win32.mak gcompris.ico gc_admin.ico gcompris-uninstal.ico \
gcompris-installer.nsi.in
-
distcore = $(PACKAGE)-core-$(VERSION)
install-data-local:
@$(NORMAL_INSTALL)
if test -d $(srcdir)/$(PACKAGE_DATA_DIR); then \
$(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR); \
- cd $(srcdir)/$(PACKAGE_DATA_DIR) ; tar cf - --exclude "Makefile.in" --exclude "*.in" --exclude "*~" --exclude "Makefile" --exclude "Makefile.am" --exclude .svn * | ( cd $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR) ; tar xf -) ; cd .. ; \
+ cd $(srcdir)/$(PACKAGE_DATA_DIR) ; tar cf - --exclude "Makefile.in" --exclude "*.in" --exclude "*~" --exclude "Makefile" --exclude "Makefile.am" --exclude .svn --mode 644 * | ( cd $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR) ; tar xf - ; find -type d -exec chmod 755 '{}' \;) ; cd .. ; \
fi
+uninstall-local:
+ -find $(DESTDIR)/$(pkgdatadir)/$(PACKAGE_DATA_DIR) -name '*' -delete
+
dist-hook:
if test -d $(PACKAGE_DATA_DIR); then \
$(mkinstalldirs) $(distdir)/$(PACKAGE_DATA_DIR); \
@@ -74,7 +76,8 @@ dist-hook:
fi
-CONFIG_CLEAN_FILES = gcompris.desktop gcompris-edit.desktop config.h.mingw
+CONFIG_CLEAN_FILES = gcompris.desktop gcompris-edit.desktop config.h.mingw \
+ gcompris-installer.nsi Makefile.mingw
clean-local:
rm -f intltool-extract intltool-merge intltool-update