Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2006-10-24 19:26:20 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2006-10-24 19:26:20 (GMT)
commit3ba73731337d58b107045b7c7c62bed728a082db (patch)
tree6b3de02782b91b7d36ee3d17e8b7253fe7011ee7 /configure.in
parentabc162d084e5da85ea3ff36657be370908c599aa (diff)
=== WARNING THIS PATCH SET HAS BEEN REVERTED ===
autotools croos compilation with mingw32 use glib headers instead of glibc (g_mkdir, g_unlink, g_stat) NEED MORE WORK. cvs maybe broken now. * Makefile.am: * acinclude.m4: * configure.in: * cross-configure.sh: script to run configure. Look variables. * po/Makefile.in.in: * src/boards/Makefile.am: * src/boards/gtans.c: * src/boards/gtans_support.c: (check_file_exists): * src/boards/py-mod-gcompris.c: (py_gcompris_child_watch_add), (py_gcompris_spawn_async): * src/gcompris/Makefile.am: * src/gcompris/binreloc.c: (_br_find_exe): * src/gcompris/board.c: * src/gcompris/board.h: * src/gcompris/file_selector.c: (parse_doc): * src/gcompris/gameutil.c: (gc_util_create_rootdir): * src/gcompris/gcompris.c: (activation_done), (gc_init): * src/gcompris/gcompris_db.c: (gc_db_init): * src/gcompris/images_selector.c: (parse_doc): * src/gcompris/menu.c: (gc_menu_load): * src/gcompris/properties.c: (gc_prop_new): * src/gcompris/sdlplayer.c: (errorv): * src/gcompris/soundutil.c:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in110
1 files changed, 21 insertions, 89 deletions
diff --git a/configure.in b/configure.in
index 4f9fe9d..861a45f 100644
--- a/configure.in
+++ b/configure.in
@@ -63,24 +63,10 @@ AM_PROG_LIBTOOL
dnl Check for SDL
SDL_VERSION=1.2.3
-
-cflags_previous=$CFLAGS
-libs_previous=$LIBS
-
-if test "x$SDL_CFLAGS" = "x" -o "x$SDL_LIBS" = "x" ; then
- AM_PATH_SDL($SDL_VERSION,
+AM_PATH_SDL($SDL_VERSION,
:,
AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
- )
-else
- AC_SUBST(SDL_CFLAGS)
- AC_SUBST(SDL_LIBS)
- echo "*** Not checking SDL. Using existing SDL_FLAGS and SDL_LIBS ***"
-fi
-
-dnl RESTAURE PREVIOUSLY SET VALUES
-CFLAGS=$cflags_previous
-LIBS=$libs_previous
+)
dnl GNOME2 GNOME_X_CHECKS
AM_PATH_GLIB_2_0
@@ -228,55 +214,27 @@ dnl
dnl === DIRECTORY DEFINITIONS ===
dnl
-if test "x$platform_win32" = "xno" ; then
+dnl Set PACKAGE_LOCALE_DIR in config.h.
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "${myprefix}/${DATADIRNAME}/locale", [GCompris locale directory])
- dnl Set PACKAGE_LOCALE_DIR in config.h.
- AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "${myprefix}/${DATADIRNAME}/locale", [GCompris locale directory])
+dnl Set PACKAGE_DATA_DIR
+PACKAGE_DATA_DIR="boards"
+AC_SUBST(PACKAGE_DATA_DIR)
+AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${myprefix}/${DATADIRNAME}", [GCompris data directory])
- dnl Set PACKAGE_DATA_DIR
- PACKAGE_DATA_DIR="boards"
- AC_SUBST(PACKAGE_DATA_DIR)
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${myprefix}/${DATADIRNAME}", [GCompris data directory])
+dnl Set PACKAGE_HELP_DIR
+PACKAGE_HELP_DIR="${myprefix}/${DATADIRNAME}/${PACKAGE}/help"
+AC_SUBST(PACKAGE_HELP_DIR)
- dnl Set PACKAGE_HELP_DIR
- PACKAGE_HELP_DIR="${myprefix}/${DATADIRNAME}/${PACKAGE}/help"
- AC_SUBST(PACKAGE_HELP_DIR)
-
- dnl Plugin Directory
- my_libdir=`eval echo "${libdir}"`
- AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "${my_libdir}", [Gcompris plugins directory])
- plugindir=$libdir/gcompris
- AC_SUBST(plugindir)
-
- dnl Python plugin Directory
- PYTHON_PLUGIN_DIR="${myprefix}/${DATADIRNAME}/${PACKAGE}/python"
- AC_SUBST(PYTHON_PLUGIN_DIR)
-
-else
- DATADIRNAME="share"
+dnl Plugin Directory
+my_libdir=`eval echo "${libdir}"`
+AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "${my_libdir}", [Gcompris plugins directory])
+plugindir=$libdir/gcompris
+AC_SUBST(plugindir)
- dnl Set PACKAGE_LOCALE_DIR in config.h for WINDOWS
- AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "../${DATADIRNAME}/locale", [GCompris locale directory])
-
- dnl Set PACKAGE_DATA_DIR
- PACKAGE_DATA_DIR="boards"
- AC_SUBST(PACKAGE_DATA_DIR)
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "../${DATADIRNAME}", [GCompris data directory])
-
- dnl Set PACKAGE_HELP_DIR
- PACKAGE_HELP_DIR="${myprefix}/${DATADIRNAME}/gnome/help/gcompris"
- AC_SUBST(PACKAGE_HELP_DIR)
-
- dnl Plugin Directory
- AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "../${DATADIRNAME}", [Gcompris plugins directory])
- plugindir=${myprefix}/${DATADIRNAME}/gcompris
- AC_SUBST(plugindir)
-
- dnl Python plugin Directory
- PYTHON_PLUGIN_DIR="${myprefix}/${DATADIRNAME}/gcompris/python"
- AC_SUBST(PYTHON_PLUGIN_DIR)
-
-fi
+dnl Python plugin Directory
+PYTHON_PLUGIN_DIR="${myprefix}/${DATADIRNAME}/${PACKAGE}/python"
+AC_SUBST(PYTHON_PLUGIN_DIR)
dnl Test for gnuchess
AC_PATH_PROG(GNUCHESS, gnuchess,no,[/usr/bin:/usr/games:/usr/local/bin:$PATH])
@@ -333,7 +291,6 @@ else
if test x$python_path != xnot ; then
PYTHON=$python_path
fi
-
AM_PATH_PYTHON(2.2)
AM_CHECK_PYTHON_HEADERS( [build_python_plugin="yes"], [build_python_plugin="no"] )
@@ -381,11 +338,10 @@ else
AC_MSG_WARN([py-build-only: Do not forget to install pygtk, pysqlite2])
fi
-fi
-
-if test x$with_sqlite = xyes; then
+ if test x$with_sqlite = xyes; then
PKG_CHECK_MODULES(SQLITE3, sqlite3,, AC_MSG_ERROR([*** SQLITE3 not found!]))
AC_DEFINE([USE_SQLITE], 1,[SQLITE Database, Profiles are enabled])
+ fi
fi
AM_CONDITIONAL(USE_SQLITE, test x$with_sqlite = xyes)
@@ -495,31 +451,7 @@ AC_SUBST(VERSION_VOICES_SV)
VERSION_VOICES_TR=1.0
AC_SUBST(VERSION_VOICES_TR)
-dnl mingw32 specific stuff.
-dnl use libgw32c
-dnl define __GW32__ and WIN32
-
-# Check platform - see if WinMain needed:
-AC_MSG_CHECKING([for native Win32])
-case "$host" in
- *-*-mingw*)
- native_win32=yes
- ;;
- *)
- native_win32=no
- ;;
-esac
-AC_MSG_RESULT([$native_win32])
-
-AM_CONDITIONAL(BUILD_MINGW32, test "$native_win32" = yes)
-if test "$native_win32" = yes; then
- LIBS="$LIBS -luuid -lole32 -lwsock32 -mno-cygwin -mms-bitfields -mwindows"
- #CFLAGS="$CFLAGS -D__GW32__ -DWIN32 -I$CROSS_ROOT/include -I$CROSS_ROOT/include/glibc"
- #CFLAGS="$CFLAGS -DWIN32"
-fi
-
AC_SUBST(CFLAGS)
-AC_SUBST(LIBS)
dnl Autoconf output
AC_OUTPUT([ gcompris.spec