Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-27 06:12:06 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-27 06:12:06 (GMT)
commit46a5ca69eedddc159f4939f415504995f0b51895 (patch)
treeb3fa43fde36e6f7dc8be0b4a13102e1c25d5df17 /configure.in
parent5a8edb08ba0f562c8f551d88a08a6ad73ad59a8c (diff)
add initial CFCLAGS to OBJCFALGS. Usefull for universal binary building.
svn path=/trunk/; revision=2557
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cc82f2e..0227ead 100644
--- a/configure.in
+++ b/configure.in
@@ -74,6 +74,7 @@ if test "x$nsbundle" = "xyes"; then
fi
NSBUNDLE_GTK_DIR="/../GTK"
NSBUNDLE_LDFLAGS="-framework Cocoa "
+ OBJCFLAGS="$OBJCFLAGS $CFLAGS"
AC_LANG_POP([Objective C])
else
AC_LANG_PUSH([Objective C])
@@ -86,7 +87,7 @@ if test "x$nsbundle" = "xyes"; then
AC_MSG_ERROR([You need GNUstep dev to use nsbundle. Make sure GNUSTEP_SYSTEM_ROOT is set." ])
fi
CPPFLAGS="$saved_CPPFLAGS"
- OBJCFLAGS=" -DGNUSTEP -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGNUSTEP_BASE_LIBRARY=1 -fconstant-string-class=NSConstantString -I$GNUSTEP_SYSTEM_ROOT/Library/Headers "
+ OBJCFLAGS="$OBJCFLAGS $CFLAGS -DGNUSTEP -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGNUSTEP_BASE_LIBRARY=1 -fconstant-string-class=NSConstantString -I$GNUSTEP_SYSTEM_ROOT/Library/Headers "
NSBUNDLE_GTK_DIR="/GTK"
NSBUNDLE_LDFLAGS="-rdynamic -fgnu-runtime -L$GNUSTEP_SYSTEM_ROOT/Library/Libraries -lgnustep-base -Wl,-rpath=\\\$\$ORIGIN/$NSBUNDLE_GTK_DIR/lib "
AC_LANG_POP([Objective C])