Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2009-02-05 00:25:57 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2009-02-05 00:25:57 (GMT)
commit48c9a62bc18d8347f994f5d21688d2914c99d124 (patch)
tree6a38bbaf4499657f696ddb7d0ec4b76fe058544c /configure.in
parent1062aef3ec80758b7e3eb3fc1cbcf3e9ca222cc4 (diff)
Miguel DE IZARRA added support for online wordlist.
This save custom data in user_dir and make a content.txt (a md5sum like file) listing custom files. Simply put this files in a web server to diffuse in classroom. GCompris clients are launch with --server and --cache-dir On start, client download content.txt from server. And when a client need a file: - first he search in server list (from content.txt) - if found, he check md5 of file in cache_dir - if md5 isn't ok, file is download in cache_dir file in cache_dir is used - if not found, search in package_dir (like now) svn path=/trunk/; revision=3720
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 800606c..443573d 100644
--- a/configure.in
+++ b/configure.in
@@ -366,6 +366,20 @@ if test x$TETEX = xno; then
AC_MSG_WARN(Couldn't find texi2html usualy in the tetex package, please install it)
fi
+
+dnl GNET support
+AC_MSG_CHECKING([wether we build with GNET (if not, networking will be disabled)])
+AC_ARG_ENABLE(gnet,
+ AC_HELP_STRING(
+ [--disable-gnet],
+ [Turn on gnet (will let GCompris fetch content from a web server)]),
+ with_gnet="$enableval", with_gnet="no")
+AC_MSG_RESULT($with_gnet)
+
+if test x$with_gnet = xyes; then
+ PKG_CHECK_MODULES(GNET, gnet-2.0,, AC_MSG_ERROR([*** GNET not found!]))
+ AC_DEFINE([USE_GNET], 1,[Networking is enabled])
+fi
dnl SQLITE support
AC_MSG_CHECKING([wether we build with SQLITE (if not profile will be disabled)])
@@ -569,6 +583,7 @@ echo "XF86VM option (--enable-xf86vidmode) = $found_xf86vidmode"
echo "SQLITE database (--enable-sqlite) = $with_sqlite (profiles depend on this)"
+echo "GNET Networking (--enable-gnet) = $with_gnet (networking depends on this)"
echo "BINRELOC (--enable-binreloc) = $br_cv_binreloc"
echo "NSBundle (--enable-nsbundle) = $nsbundle"