Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-22 13:02:00 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-22 13:02:00 (GMT)
commit5aab6396aee5dc1e7059726c77a679bbfbb4ebdd (patch)
treeba18b88ca47e805b826b88cbf4c53b4071ec31c5 /configure.in
parentb17ea5076d4bf734ac53ad699ba47de4ff94b724 (diff)
reloc gtk libs for osx bundle. TODO: fix for no osx.
svn path=/trunk/; revision=2536
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index eb4d081..81595ff 100644
--- a/configure.in
+++ b/configure.in
@@ -59,6 +59,7 @@ AC_ARG_ENABLE(nsbundle,
NSBUNDLE_CPPFLAGS=
NSBUNDLE_LDFLAGS=
+NSBUNDLE_GTK_DIR=
#check header for nsbundle
if test "x$nsbundle" = "xyes"; then
@@ -71,6 +72,7 @@ if test "x$nsbundle" = "xyes"; then
if test "x$NSFoundation" = "x$no"; then
AC_MSG_ERROR([You need development tools to use nsbundle. Make sure XCode is installed." ])
fi
+ NSBUNDLE_GTK_DIR="../GTK"
NSBUNDLE_LDFLAGS="-framework Cocoa "
AC_LANG_POP([Objective C])
else
@@ -85,7 +87,8 @@ if test "x$nsbundle" = "xyes"; then
fi
CPPFLAGS="$saved_CPPFLAGS"
NSBUNDLE_CPPFLAGS=" -I$GNUSTEP_SYSTEM_ROOT/Library/Headers "
- NSBUNDLE_LDFLAGS="-rdynamic -fgnu-runtime -L$GNUSTEP_SYSTEM_ROOT/Library/Libraries -lgnustep-base"
+ NSBUNDLE_GTK_DIR="GTK"
+ NSBUNDLE_LDFLAGS="-rdynamic -fgnu-runtime -L$GNUSTEP_SYSTEM_ROOT/Library/Libraries -lgnustep-base -Wl,-rpath=\\\$\$ORIGIN/$NSBUNDLE_GTK_DIR "
AC_LANG_POP([Objective C])
fi
AC_DEFINE_UNQUOTED(NSBUNDLE, 1, [ Define to 1 to use NSBundle for relocation (OSX/GNUstep) ])
@@ -98,6 +101,7 @@ _AM_DEPENDENCIES([OBJC])
AC_SUBST(NSBUNDLE_CPPFLAGS)
AC_SUBST(NSBUNDLE_LDFLAGS)
+AC_SUBST(NSBUNDLE_GTK_DIR)
# Todo: add a AC_ARG_WITH to allow change.
bundlename=GCompris