Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2006-10-17 22:14:46 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2006-10-17 22:14:46 (GMT)
commit6117d444e9e9a6cfbbc53d357985802b191bd043 (patch)
tree73e73e867b71493e4c1f6aa8e3d33f05cdfde448 /configure.in
parent036ed53e7bf193f4c85226ddd6d41e176d9e2de0 (diff)
- Updated windows makefiles
- Cleanup configure.in to no more depend on pyxml and python-gnome.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index c3d1c47..629fa99 100644
--- a/configure.in
+++ b/configure.in
@@ -310,15 +310,14 @@ REQUIRE_PYTHON=""
if test x$build_python_plugin = xno; then
AC_MSG_NOTICE([Python plugin is disabled.])
else
- dnl Python interpreter is available so check for pygtk and gnome-python
- PKG_CHECK_MODULES(PYGTK, pygtk-2.0 gnome-python-2.0)
+ dnl Python interpreter is available so check for pygtk
+ PKG_CHECK_MODULES(PYGTK, pygtk-2.0)
if test x$py_build_only = xno; then
AM_CHECK_PYMOD(gtk,,,AC_MSG_ERROR([*** pygtk installed but not visible from python ]))
- AM_CHECK_PYMOD(gnome.canvas,,,AC_MSG_ERROR([*** pygtk installed but not visible from python ]))
- AM_CHECK_PYMOD(xml.dom.DOMImplementation,,,AC_MSG_WARN([*** pyxml missing ]))
+ dnl AM_CHECK_PYMOD(xml.dom.DOMImplementation,,,AC_MSG_WARN([*** pyxml missing ]))
dnl Set this variable for the .spec.in file
- REQUIRE_PYTHON="python gnome-python gnome-python-canvas pygtk2.0"
+ REQUIRE_PYTHON="python pygtk2.0"
dnl with gnome-python >= 2.10 gnome.canvas is obsolete. use gnomecanvas
dnl gnomecanvas not supported yet in gcompris
@@ -336,7 +335,7 @@ else
else
AC_MSG_WARN([py-build-only: Skipping python modules dependancies])
- AC_MSG_WARN([py-build-only: Do not forget to install pygtk, gnome-python, pysqlite2 and pyxml])
+ AC_MSG_WARN([py-build-only: Do not forget to install pygtk, pysqlite2])
fi
if test x$with_sqlite = xyes; then