Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2006-08-11 13:17:42 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2006-08-11 13:17:42 (GMT)
commit7c9d8c5f8483c6c389b31459cc297ed6d2cdb837 (patch)
tree67652b450e729b9bdc0c8f93b686065c4ee8d549 /configure.in
parentf36b9357b877bc24da03f367aad0f61ee9eac460 (diff)
- Fixed potential the exit code to avoid a potential core dump when exiting GCompris
Fixed administration. When leave the boards module, GCompris was quitting. This bug has been introduced in a fix the 2006-07-10. Now leaving GCompris in administration mode, there is no more segfaults. * boards/oscar_and_friends/scene1_0.png: improved by Josef Vybiral * configure.in: added support for gnet (disabled by default) * src/boards/python/admin/module_boards.py: fixed management of the module state. no more double stop modules. * src/boards/python/admin/module_users.py: - * src/boards/python/administration.py: - * src/boards/python/oscar_and_friends.py: changed text coordinate and colors * src/gcompris/Makefile.am: added gc_net.* * src/gcompris/gc_net.c: empty now, will hold the network code * src/gcompris/gc_net.h: - * src/gcompris/board.c: (board_pause), (board_stop), (get_board_playing): * src/gcompris/board.h: cleanup, removed pause board state saving. now board_pause takes an argument, no more a toggle. * src/gcompris/board_config.c: (gcompris_combo_box_changed), (my_strcmp): added several static. code cleanup. * src/gcompris/gameutil.c: (gcompris_load_pixmap), (gcompris_dialog), (item_event_ok): prepared net code. * src/gcompris/gcompris.c: (gcompris_end_board), (cleanup), (gcompris_exit), (quit_cb), (gcompris_init): fixed quit sequence. now a real exit is done after gtk_main_quit * src/gcompris/gcompris.h: added gc_net * src/gcompris/properties.c: (gcompris_properties_new): added server option * src/gcompris/properties.h: - * src/gcompris/sdlplayer.c: (sdlplayer_init), (sdlplayer_quit), (sdlplayer_bg): replaced printf by g_warning * src/gcompris/skin.c: (gcompris_image_to_skin): no more return an empty skin but the default one anyway. It will fail later on anyway if the image is not available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index da0d875..d2aec6d 100644
--- a/configure.in
+++ b/configure.in
@@ -267,6 +267,20 @@ AC_ARG_ENABLE(sqlite,
with_sqlite="$enableval", with_sqlite="yes")
AC_MSG_RESULT($with_sqlite)
+dnl GNET support
+AC_MSG_CHECKING([wether we build with GNET (if not, networking will be disabled)])
+AC_ARG_ENABLE(gnet,
+ AC_HELP_STRING(
+ [--disable-gnet],
+ [Turn on gnet (will let GCompris fetch content from a web server)]),
+ with_gnet="$enableval", with_gnet="no")
+AC_MSG_RESULT($with_gnet)
+
+if test x$with_gnet = xyes; then
+ PKG_CHECK_MODULES(GNET, gnet-2.0,, AC_MSG_ERROR([*** GNET not found!]))
+ AC_DEFINE([USE_GNET], 1,[Networking is enabled])
+fi
+
dnl check for python
AC_ARG_WITH(python,AC_HELP_STRING(
[--with-python=path],
@@ -501,6 +515,8 @@ echo "XF86VM option (--enable-xf86vidmode) = $found_xf86vidmode"
echo "SQLITE database (--enable-sqlite) = $with_sqlite (profiles depend on this)"
+echo "GNET Networking (--enable-gnet) = $with_gnet (networking depends on this)"
+
echo
echo gcompris will be installed in ${prefix}
echo to compile and install in in another directory