Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bruno.coudoin@free.fr>2009-07-12 19:01:58 (GMT)
committer Bruno Coudoin <bruno.coudoin@free.fr>2009-07-12 19:01:58 (GMT)
commitab9da61f426b7346f228a9d772d951dc97f22816 (patch)
tree62b1638703e4ba02c5641afe9bab9223bd21ee5e /configure.in
parent32a836eb9276ce42d655483f5964e5cff62fd0a4 (diff)
Cleanup concerning WIN32 paltform. Removed redundant cases.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 7 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index bb8bf20..2c7b8e5 100644
--- a/configure.in
+++ b/configure.in
@@ -231,18 +231,6 @@ else
fi
dnl WIN32 Specifics
-AC_MSG_CHECKING([for native Win32])
-case "$host" in
- *-*-mingw*)
- native_win32=yes
- ;;
- *)
- native_win32=no
- ;;
-esac
-AC_MSG_RESULT([$native_win32])
-AM_CONDITIONAL(OS_WIN32, test "$native_win32" = yes)
-
AC_MSG_CHECKING([for Win32 platform in general])
case "$host" in
*-*-mingw*|*-*-cygwin*)
@@ -254,6 +242,13 @@ case "$host" in
esac
AC_MSG_RESULT($platform_win32)
AM_CONDITIONAL(PLATFORM_WIN32, test "$platform_win32" = yes)
+AM_CONDITIONAL(BUILD_MINGW32, test "$platform_win32" = yes)
+if test x"$platform_win32" = xyes; then
+ LIBS="$LIBS -luuid -lole32 -lwsock32 -mno-cygwin -mms-bitfields -mwindows -mconsole"
+ #CFLAGS="$CFLAGS -D__GW32__ -DWIN32 -I$CROSS_ROOT/include -I$CROSS_ROOT/include/glibc"
+ #CFLAGS="$CFLAGS -DWIN32"
+fi
+
# Ensure MSVC-compatible struct packing convention is used when
# compiling for Win32 with gcc. GTK+ uses this convention, so we must, too.
@@ -475,24 +470,6 @@ dnl use libgw32c
dnl define __GW32__ and WIN32
# Check platform - see if WinMain needed:
-AC_MSG_CHECKING([for native Win32])
-case "$host" in
- *-*-mingw*)
- native_win32=yes
- ;;
- *)
- native_win32=no
- ;;
-esac
-AC_MSG_RESULT([$native_win32])
-
-AM_CONDITIONAL(BUILD_MINGW32, test "$native_win32" = yes)
-if test "$native_win32" = yes; then
- LIBS="$LIBS -luuid -lole32 -lwsock32 -mno-cygwin -mms-bitfields -mwindows -mconsole"
- #CFLAGS="$CFLAGS -D__GW32__ -DWIN32 -I$CROSS_ROOT/include -I$CROSS_ROOT/include/glibc"
- #CFLAGS="$CFLAGS -DWIN32"
-fi
-
AC_SUBST(CFLAGS)
AC_SUBST(LIBS)