Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bruno.coudoin@free.fr>2009-07-14 21:53:12 (GMT)
committer Bruno Coudoin <bruno.coudoin@free.fr>2009-07-14 21:53:12 (GMT)
commitf3373a11998b5269a9fbf22ca717a3c33051d059 (patch)
tree6c7f9d868f0ef7f1754243f89be0771098bb047d /configure.in
parentad6e6d899ae2e25b541a72f04a2f0cef0539e341 (diff)
Reorganisation of the sound playing in GCompris to split the
high level audio file management and the low level audio player (gstreamer based for instance). The goal behind this is to make room for an integration of the GCOMPRIS 8.3 branch SDL Mixer player. This way we will be able to resync the windows and master branch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2c7b8e5..91e0f98 100644
--- a/configure.in
+++ b/configure.in
@@ -19,8 +19,7 @@ dnl
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(GCOMPRIS, dnl
- [gtk+-2.0 >= $GTK_REQUIRED dnl
- gstreamer-0.10])
+ [gtk+-2.0 >= $GTK_REQUIRED])
AC_SUBST(GCOMPRIS_CFLAGS)
AC_SUBST(GCOMPRIS_LIBS)
@@ -362,6 +361,26 @@ if test x$TETEX = xno; then
fi
+dnl SDLMixer support
+AC_MSG_CHECKING([wether we build with SDLMixer (will replace gstreamer by sdl mixer if enabled)])
+AC_ARG_ENABLE(sdlmixer,
+ AC_HELP_STRING(
+ [--enable-sdlmixer],
+ [Turn on sdl mixer (will replace gstreamer by sdl mixer)]),
+ with_sdlmixer="$enableval", with_sdlmixer="no")
+AC_MSG_RESULT($with_sdlmixer)
+
+if test x$with_sdlmixer = xyes; then
+ PKG_CHECK_MODULES(AUDIO, sdl,, AC_MSG_ERROR([*** SDL Mixer not found!]))
+ AC_DEFINE([USE_SDLMIXER], 1,[sdl mixer is enabled])
+else
+ dnl Default is gstreamer
+ PKG_CHECK_MODULES(AUDIO, gstreamer-0.10,, AC_MSG_ERROR([*** GSTREAMER not found!]))
+ AC_DEFINE([USE_GSTREAMER], 1,[gstreamer is enabled])
+fi
+AC_SUBST(AUDIO_CFLAGS)
+AC_SUBST(AUDIO_LIBS)
+
dnl GNET support
AC_MSG_CHECKING([wether we build with GNET (if not, networking will be disabled)])
AC_ARG_ENABLE(gnet,
@@ -554,6 +573,7 @@ echo "SQLITE database (--enable-sqlite) = $with_sqlite (profiles depend o
echo "GNET Networking (--enable-gnet) = $with_gnet (networking depends on this)"
echo "BINRELOC (--enable-binreloc) = $br_cv_binreloc"
echo "NSBundle (--enable-nsbundle) = $nsbundle"
+echo "SDL Mixer (--enable-sdlmixer) = $with_sdlmixer (default is gstreamer)"
echo