Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSascha Silbe <sascha-pgp@silbe.org>2011-07-06 20:39:05 (GMT)
committer Sascha Silbe <sascha-pgp@silbe.org>2011-07-06 20:39:30 (GMT)
commit8bce5a16618b45d519d322da77e93b663e0c8c55 (patch)
tree0157d3890551953b0e252797575fb756ae581025 /setup.py
parent9997e606caaecd49df3cc215b90486980a591afe (diff)
setup.py: fix --root support for D-Bus service files
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0624562..153f084 100755
--- a/setup.py
+++ b/setup.py
@@ -74,7 +74,7 @@ class install_dbus(Command): # pylint: disable=C0103,R0904
def process_template(self, template_path, service_path):
"""Copy template_path to service_path, replacing format specifiers.
"""
- variables = {'install_dir': self.install_dir, 'root': self.root}
+ variables = {'install_dir': self.install_dir[len(self.root):]}
with file(service_path, 'w') as service_file:
for line in file(template_path):
service_file.write(line % variables)