Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2009-03-03 19:55:39 (GMT)
committer Colin Walters <walters@verbum.org>2009-03-03 19:55:39 (GMT)
commitb22ac84b4d31f0c644ca4b52586345f5c87a3135 (patch)
tree530db90760e7d3aa64d306a5da6ae82e032e8c9f /Makefile.am
parent870698f1613ab9f5bf89a19b9e08a4909b8d7a38 (diff)
Remove hand-written .gir files, move PEP-8 inquisition into top Makefile.am
We have more comprehensive testing in tests/scanner and tests/everything, and these tests were designed from a time when we were trying to make the g-ir-generate output exactly match the .gir, which has not been true for some time and will not be in the future.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a9b67c..2a4de03 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,3 +50,9 @@ release-tag:
upload-release: $(distdir).tar.gz
scp $(distdir).tar.gz gnome.org:
ssh gnome.org install-module $(distdir).tar.gz
+
+check-local:
+ @echo " PEP-8 INQUISITION"
+ @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat
+ @echo " CHECK Pyflakes"
+ @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pyflakes.py