Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 706b5e3..4aefb0a 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -8,6 +8,10 @@ bin_PROGRAMS = g-ir-compiler g-ir-generate
bin_SCRIPTS = g-ir-scanner
EXTRA_DIST = g-ir-scanner
+g-ir-scanner: g-ir-scanner.in Makefile
+ sed -e s,@libdir\@,$(libdir), $< > $@.tmp && mv $@.tmp $@
+ chmod a+x $@
+
g_ir_compiler_SOURCES = compiler.c
g_ir_compiler_CFLAGS = $(GIREPO_CFLAGS)
g_ir_compiler_LDADD = \