Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAleksey Lim <alsroot@member.fsf.org>2009-02-06 18:29:56 (GMT)
committer Aleksey Lim <alsroot@member.fsf.org>2009-02-06 18:29:56 (GMT)
commit6049e8b831229e237769627faa0699f445f41fe7 (patch)
tree370bcfd954feff76d49d557c869f8c5f97dab0c6 /configure.ac
parentf7cd113b68981880a0cc7a5dc4f872f04f00ac4c (diff)
Check dependencies in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba2be0f..ef67921 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,5 +127,10 @@ dnl set proper LDFLAGS for plugins
GST_PLUGIN_LDFLAGS='-module -avoid-version -export-symbols-regex [_]*\(gst_\|Gst\|GST_\).*'
AC_SUBST(GST_PLUGIN_LDFLAGS)
+dnl check espeak dependencies
+AC_CHECK_LIB(espeak, espeak_Initialize,, AC_MSG_ERROR())
+PKG_CHECK_MODULES(GIO, gio-2.0)
+PKG_CHECK_MODULES(GST_AUDIO, gstreamer-audio-0.10)
+
AC_OUTPUT(Makefile m4/Makefile src/Makefile)