Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJulio Reyes <nemesiscodex@gmail.com>2013-07-05 14:13:11 (GMT)
committer Julio Reyes <nemesiscodex@gmail.com>2013-07-05 14:13:11 (GMT)
commitb6db5b8af0af7ebfdd44cb53b09d63b819989338 (patch)
treeca439018bfa1c34c97bdaed4ec0f20bc36bd678f /configure.ac
Initial CommitHEADmaster
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac84
1 files changed, 84 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f444409
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,84 @@
+AC_INIT([Sugar],[0.96.3],[],[sugar])
+
+AC_PREREQ([2.59])
+
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([configure.ac])
+
+SUCROSE_VERSION="0.96.2"
+AC_SUBST(SUCROSE_VERSION)
+
+AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip])
+
+AM_MAINTAINER_MODE
+
+AM_PATH_PYTHON
+
+PKG_CHECK_MODULES(SHELL, pygtk-2.0 gtk+-2.0 gconf-2.0)
+
+# Setup GETTEXT
+#
+ALL_LINGUAS="af am ar aym bg bi bn_IN bn ca cs da de dz el en es fa_AF fa ff fil fr gu ha he hi ht hu id ig is it ja km ko kos mg mi mk ml mn mr ms mvo nb ne nl pa pap pl ps pt_BR pt quz ro ru rw sd si sk sl sq sv sw ta te th tr tvl tzo ug ur vi wa yo zh_CN zh_TW"
+
+GETTEXT_PACKAGE=sugar
+AC_PROG_INTLTOOL([0.33])
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Gettext package])
+AM_GLIB_GNU_GETTEXT
+
+AC_ARG_ENABLE(update-mimedb,
+ AC_HELP_STRING([--disable-update-mimedb],
+ [disable the update-mime-database after install [default=no]]),,
+ enable_update_mimedb=yes)
+AM_CONDITIONAL(ENABLE_UPDATE_MIMEDB, test x$enable_update_mimedb = xyes)
+
+# Verify that gconftool is installed
+#
+AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
+
+if test "$GCONFTOOL" = no; then
+ AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
+fi
+
+AM_GCONF_SOURCE_2
+
+
+AC_CONFIG_FILES([
+bin/Makefile
+bin/sugar
+data/icons/Makefile
+data/Makefile
+data/sugar-emulator.desktop
+extensions/cpsection/aboutcomputer/Makefile
+extensions/cpsection/aboutme/Makefile
+extensions/cpsection/datetime/Makefile
+extensions/cpsection/frame/Makefile
+extensions/cpsection/keyboard/Makefile
+extensions/cpsection/language/Makefile
+extensions/cpsection/modemconfiguration/Makefile
+extensions/cpsection/Makefile
+extensions/cpsection/network/Makefile
+extensions/cpsection/power/Makefile
+extensions/cpsection/updater/backends/Makefile
+extensions/cpsection/updater/Makefile
+extensions/deviceicon/Makefile
+extensions/globalkey/Makefile
+extensions/Makefile
+Makefile
+po/Makefile.in
+src/jarabe/config.py
+src/jarabe/controlpanel/Makefile
+src/jarabe/desktop/Makefile
+src/jarabe/frame/Makefile
+src/jarabe/intro/Makefile
+src/jarabe/journal/Makefile
+src/jarabe/Makefile
+src/jarabe/model/Makefile
+src/jarabe/util/Makefile
+src/jarabe/util/telepathy/Makefile
+src/jarabe/view/Makefile
+src/Makefile
+])
+
+AC_OUTPUT
+