Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..e5026ee
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+import os
+import sys
+
+if len(sys.argv) > 1 and '--no-sugar' == sys.argv[1]:
+ # Remove the argument from the stack so we don't cause problems
+ # for distutils
+ sys.argv.pop(1)
+
+ import glob, os.path, string
+ from distutils.core import setup
+
+ DATA_FILES = [
+ ('icons', glob.glob('icons/*')),
+ ('images', glob.glob('images/*')),
+ ('/usr/share/applications', ['turtleart.desktop'])
+ ]
+
+ setup (name = 'Turtle Art',
+ description = "A LOGO-like tool for teaching programming",
+ author = "Walter Bender",
+ author_email = "walter.bender@gmail.com",
+ version = '0.9.4',
+ packages = ['TurtleArt'],
+ scripts = ['turtleart'],
+ data_files = DATA_FILES,
+ )
+else:
+ from sugar.activity import bundlebuilder
+
+ if __name__ == "__main__":
+ bundlebuilder.start()