Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/0.84/platform/python-olpcgames/SPECS/python-olpcgames.spec
diff options
context:
space:
mode:
Diffstat (limited to '0.84/platform/python-olpcgames/SPECS/python-olpcgames.spec')
-rw-r--r--0.84/platform/python-olpcgames/SPECS/python-olpcgames.spec69
1 files changed, 69 insertions, 0 deletions
diff --git a/0.84/platform/python-olpcgames/SPECS/python-olpcgames.spec b/0.84/platform/python-olpcgames/SPECS/python-olpcgames.spec
new file mode 100644
index 0000000..fb6a9c5
--- /dev/null
+++ b/0.84/platform/python-olpcgames/SPECS/python-olpcgames.spec
@@ -0,0 +1,69 @@
+%define date 20090129
+#%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from
+distutils.sysconfig import get_python_lib; print get_python_lib()")}
+%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from
+distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+
+Name: python-olpcgames
+Version: 1.6
+%if 0%{?suse_version}
+Release: 1
+%else
+Release: 1%{?dist}
+%endif
+Summary: Utilities for developing games on the OLPC platform
+
+Group: Development/Languages
+License: BSD
+URL: http://wiki.laptop.org/go/OLPCGames
+Source0: http://dev.laptop.org/~mcfletch/OLPCGames/OLPCGames-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{_id_u} -n)
+BuildArch: noarch
+
+BuildRequires: python-devel
+BuildRequires: python-setuptools
+BuildRequires: gtk2-devel
+BuildRequires: python-gtk-devel
+BuildRequires: python-pyx
+
+Requires: gtk2
+Requires: python-pygame
+Requires: python-gtk
+
+%description
+This python package contains various resources and utility classes for
+making games on the OLPC system. Specifically it enables using PyGame in the
+Sugar environment.
+
+
+%prep
+%setup -q -n OLPCGames-%{version}
+
+
+%build
+python ./setup.py build
+
+
+%install
+rm -rf %{buildroot}
+python ./setup.py install --prefix=%{buildroot}/%{_prefix}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc NEWS README
+# For noarch packages: sitelib
+%{python_sitelib}/OLPCGames/
+%{python_sitelib}/%{name}*.egg-info
+# For arch-specific packages: sitearch
+#%{python_sitearch}/*
+
+
+%changelog
+* Mon Jan 26 2009 Fabian Affolter <fabian@bernewireless.net> - 1.6-1
+- Initial package for Fedora
+