Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py55
1 files changed, 55 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..5548d9a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,55 @@
+#!/usr/bin/env python
+import sys
+from setuptools import setup
+from setuptools import find_packages
+from pilas import pilasversion
+
+def error(biblioteca, web):
+ print "Error, no se encuentra la biblioteca '%s' (de %s)" %(biblioteca, web)
+ sys.exit(1)
+
+
+try:
+ import Box2D
+except ImportError:
+ error("box2d", "http://code.google.com/p/pybox2d")
+
+
+setup(
+ name='pilas',
+ version=pilasversion.VERSION,
+ description='A simple to use video game framework.',
+ author='Hugo Ruscitti',
+ author_email='hugoruscitti@gmail.com',
+ install_requires=[
+ 'setuptools',
+ ],
+ packages=['pilas', 'pilas.actores', 'pilas.dispatch',
+ 'pilas.ejemplos', 'pilas.motores',
+ 'pilas.interfaz', 'pilas.video',
+ 'pilas.cargador'],
+ url='http://www.pilas-engine.com.ar',
+ include_package_data = True,
+ package_data = {
+ 'images': ['pilas/data/*', 'pilas/ejemplos/data/*',
+ 'pilas/data/fondos/*', 'pilas/data/juegobase/*',
+ 'pilas/data/juegobase/data/*',
+ 'pilas/cargador/ejemplos',
+ 'pilas/cargador/data'],
+ },
+
+ scripts=['bin/pilas'],
+
+ classifiers = [
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
+ 'Natural Language :: Spanish',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Games/Entertainment',
+ 'Topic :: Education',
+ 'Topic :: Software Development :: Libraries',
+ ],
+ )
+