Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..8682094
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,14 @@
+#!/usr/bin/python
+from distutils.core import setup, Extension
+
+main = Extension( 'pyxkb',
+ define_macros = [('_LINUX',None)],
+ libraries = ['X11', 'gobject-2.0', 'gmodule-2.0', 'xklavier', 'glib-2.0'],
+ include_dirs = ['/usr/include/glib-2.0', '/usr/lib/glib-2.0/include', '/usr/include/libxml2'],
+ sources = ['pyxkb.c'],
+ extra_compile_args = ['-Wall'])
+
+setup( name = "pyxkb",
+ version = "0.1",
+ description = "Module for manipulating XKB",
+ ext_modules = [main])