Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTomeu Vizoso <tomeu@sugarlabs.org>2009-01-14 19:24:47 (GMT)
committer Tomeu Vizoso <tomeu@sugarlabs.org>2009-01-14 19:24:47 (GMT)
commit03001ff5cc0579788c72d0125e2599d73ad60ae9 (patch)
treeecbccc0c36bf962964628c45e5ce88cfc17bd04f /configure.ac
parent9c7bad43011ee2f9a8e0837bd2372dea3b710244 (diff)
Add python bindings for libevinceHEADmaster
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4eb5e26..a26dece 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,9 @@ AC_PREREQ(2.57)
AC_INIT([Evince],[2.25.4],[http://bugzilla.gnome.org/enter_bug.cgi?product=evince],[evince])
AM_INIT_AUTOMAKE([1.9 dist-bzip2 no-dist-gzip])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([configure.ac])
+
EV_API_VERSION=2.20
AC_SUBST(EV_API_VERSION)
@@ -203,6 +206,22 @@ AC_ARG_ENABLE(embed,
if test "x${enableval}" = "xyes"; then
AC_DEFINE([BUILD_EMBED],[1],[Build embed lib.])
+
+ AM_PATH_PYTHON
+ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+ dnl Check for pygtk
+ AC_MSG_CHECKING(for pygtk-2.0)
+ PKG_CHECK_MODULES([PYGTK], [pygtk-2.0], [], [AC_MSG_ERROR([Pygtk-2.0 needed])])
+
+ dnl Find pygtk codegen
+ AC_MSG_CHECKING(for pygtk codegen)
+ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+ AC_SUBST(PYGTK_CODEGEN)
+ AC_MSG_RESULT($PYGTK_CODEGEN)
+
+ PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+ AC_SUBST(PYGTK_DEFSDIR)
fi
AM_CONDITIONAL(BUILD_EMBED_LIB, test x$BUILD_EMBED_LIB = "xyes")
@@ -483,6 +502,7 @@ libdocument/Makefile
Makefile
po/Makefile.in
properties/Makefile
+python/Makefile
shell/Makefile
test/Makefile
thumbnailer/Makefile