Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorcarlosgc <carlosgc@e12069bd-dc25-0410-a696-d39a8afcd844>2008-03-14 11:13:01 (GMT)
committer carlosgc <carlosgc@e12069bd-dc25-0410-a696-d39a8afcd844>2008-03-14 11:13:01 (GMT)
commit6a8a1acdeedc44661f41b58d3568512a4c0a9828 (patch)
tree1b0c547f01b72d314f923e3e76e19627952c48e5 /configure.ac
parent939605e1a460bb1a7032728dfda962db9008654e (diff)
2008-03-14 Carlos Garcia Campos <carlosgc@gnome.org>
* configure.ac: * backend/pdf/ev-poppler.cc: Fix build with poppler >= 0.7.2 git-svn-id: svn+ssh://svn.gnome.org/svn/evince/trunk@2965 e12069bd-dc25-0410-a696-d39a8afcd844
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f4b3b7..4b0ddda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,6 +218,15 @@ if test "x$enable_pdf" = "xyes"; then
AC_CHECK_FUNCS(poppler_page_get_image)
LIBS=$evince_save_LIBS
+ POPPLER_MAJOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/0\.\([[0-9]]*\)\(\.\([[0-9]]*\)\)\?/\1/'`
+ POPPLER_MINOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/0\.\([[0-9]]*\)\(\.\([[0-9]]*\)\)\?/\3/'`
+ if test -z "$POPPLER_MINOR_VERSION"; then
+ POPPLER_MINOR_VERSION=0
+ fi
+
+ AC_DEFINE_UNQUOTED([POPPLER_MAJOR_VERSION], $POPPLER_MAJOR_VERSION, [Poppler major version number])
+ AC_DEFINE_UNQUOTED([POPPLER_MINOR_VERSION], $POPPLER_MINOR_VERSION, [Poppler minor version number])
+
PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)
if test x$enable_cairo_pdf == xyes; then
AC_DEFINE([HAVE_CAIRO_PDF], [1], [defined if cairo-pdf is available])